aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 15:49:42 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 15:49:42 +0000
commit4dd53d49104787d7b52f1a799500497c5846e35e (patch)
treef514e594a9dc9ea6896c3e2c2446c0711cdea947 /package
parent22ec767935be9f6d8681fbe155baf7935ce9ce06 (diff)
downloadupstream-4dd53d49104787d7b52f1a799500497c5846e35e.tar.gz
upstream-4dd53d49104787d7b52f1a799500497c5846e35e.tar.bz2
upstream-4dd53d49104787d7b52f1a799500497c5846e35e.zip
[x86] move x86 specific ide/pata modules to x86' modules.mk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32846 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/block.mk64
1 files changed, 0 insertions, 64 deletions
diff --git a/package/kernel/modules/block.mk b/package/kernel/modules/block.mk
index 1f343dd93c..cdf3effc5a 100644
--- a/package/kernel/modules/block.mk
+++ b/package/kernel/modules/block.mk
@@ -489,70 +489,6 @@ endef
$(eval $(call KernelPackage,ide-it821x))
-define KernelPackage/cs5535
- TITLE:=NSC/AMD CS5535 chipset support
- DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_BLK_DEV_CS5535
- FILES=$(LINUX_DIR)/drivers/ide/cs5535.ko
- AUTOLOAD:=$(call AutoLoad,30,cs5535,1)
- $(call AddDepends/ide)
-endef
-
-define KernelPackage/cs5535/description
- Kernel module for the NSC/AMD CS5535 companion chip
-endef
-
-$(eval $(call KernelPackage,cs5535))
-
-
-define KernelPackage/cs5536
- TITLE:=AMD CS5536 chipset support
- DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_BLK_DEV_CS5536
- FILES=$(LINUX_DIR)/drivers/ide/cs5536.ko
- AUTOLOAD:=$(call AutoLoad,30,cs5536,1)
- $(call AddDepends/ide)
-endef
-
-define KernelPackage/cs5536/description
- Kernel module for the AMD CS5536 Geode LX companion chip
-endef
-
-$(eval $(call KernelPackage,cs5536))
-
-
-define KernelPackage/pata-cs5535
- TITLE:=CS5535 PATA support
- DEPENDS:=@TARGET_x86 @PCI_SUPPORT
- KCONFIG:=CONFIG_PATA_CS5535
- FILES=$(LINUX_DIR)/drivers/ata/pata_cs5535.ko
- AUTOLOAD:=$(call AutoLoad,30,pata_cs5535,1)
- $(call AddDepends/ata)
-endef
-
-define KernelPackage/pata-cs5535/description
- Kernel module for the NSC/AMD CS5535 companion chip
-endef
-
-$(eval $(call KernelPackage,pata-cs5535))
-
-
-define KernelPackage/pata-cs5536
- TITLE:=CS5536 PATA support
- DEPENDS:=@TARGET_x86 @PCI_SUPPORT
- KCONFIG:=CONFIG_PATA_CS5536
- FILES=$(LINUX_DIR)/drivers/ata/pata_cs5536.ko
- AUTOLOAD:=$(call AutoLoad,30,pata_cs5536,1)
- $(call AddDepends/ata)
-endef
-
-define KernelPackage/pata-cs5536/description
- Kernel module for the AMD CS5536 Geode LX companion chip
-endef
-
-$(eval $(call KernelPackage,pata-cs5536))
-
-
define KernelPackage/libsas
SUBMENU:=$(BLOCK_MENU)
TITLE:=SAS Domain Transport Attributes