aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-07-08 09:01:42 +0000
committerJohn Crispin <blogic@openwrt.org>2013-07-08 09:01:42 +0000
commit3f60f761847b4304401f444bb1eb608bccb56b0e (patch)
treefb92ddd7e4245b89cd7976605ed1c1af1c746fda /package
parent995a33804f45a12302c235cdfd59fcb1a6908692 (diff)
downloadupstream-3f60f761847b4304401f444bb1eb608bccb56b0e.tar.gz
upstream-3f60f761847b4304401f444bb1eb608bccb56b0e.tar.bz2
upstream-3f60f761847b4304401f444bb1eb608bccb56b0e.zip
ubox: add a uci-default script for fstab generation
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37199 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/system/ubox/Makefile3
-rw-r--r--package/system/ubox/files/fstab.default1
2 files changed, 3 insertions, 1 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index 3824148f93..e964506385 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -48,9 +48,10 @@ define Package/ubox/install
endef
define Package/block-mount/install
- $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/
+ $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
$(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
+ $(INSTALL_DATA) ./files/fstab.default $(1)/etc/uci-defaults/10-fstab
$(INSTALL_DATA) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
diff --git a/package/system/ubox/files/fstab.default b/package/system/ubox/files/fstab.default
new file mode 100644
index 0000000000..dd4ba1c485
--- /dev/null
+++ b/package/system/ubox/files/fstab.default
@@ -0,0 +1 @@
+[ ! -f /etc/config/fstab ] && ( block detect > /etc/config/fstab )