aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-08-23 15:17:15 +0000
committerNicolas Thill <nico@openwrt.org>2005-08-23 15:17:15 +0000
commit3504cd9c0abe8f453e0309dd84891b769fba1939 (patch)
treef3b4a526e8947dcef1402633f0f1770dd4cf36d0 /package
parent2cc1f7ba55c858ac9c449c2ff8ee6a4027275b3f (diff)
downloadupstream-3504cd9c0abe8f453e0309dd84891b769fba1939.tar.gz
upstream-3504cd9c0abe8f453e0309dd84891b769fba1939.tar.bz2
upstream-3504cd9c0abe8f453e0309dd84891b769fba1939.zip
add missing pg_config.h header to staging_dir, required to build php5 extension
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1737 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/postgresql/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/postgresql/Makefile b/package/postgresql/Makefile
index 1f37bb7527..d83f1afb85 100644
--- a/package/postgresql/Makefile
+++ b/package/postgresql/Makefile
@@ -97,6 +97,7 @@ $(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
mkdir -p $(STAGING_DIR)/usr/include
cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(STAGING_DIR)/usr/include/
+ cp -fpR $(PKG_INSTALL_DIR)/usr/include/pg_config.h $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgresql $(STAGING_DIR)/usr/include/
mkdir -p $(STAGING_DIR)/usr/lib
@@ -109,6 +110,7 @@ uninstall-dev:
rm -rf \
$(STAGING_DIR)/usr/include/libpq \
$(STAGING_DIR)/usr/include/libpq-fe.h \
+ $(STAGING_DIR)/usr/include/pg_config.h \
$(STAGING_DIR)/usr/include/postgres_ext.h \
$(STAGING_DIR)/usr/include/postgresql \
$(STAGING_DIR)/usr/lib/libpq.{a,so*} \