aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-07-01 10:52:35 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-07-01 10:52:35 +0000
commit17a7b9cb506ed861d9589a3a8c34c6a430b06d5a (patch)
tree018ea838513e48373940daa0ec9ebc4c13a10f7e /package
parent573f9156dcf034c03927c1f8f749ca22a12d0794 (diff)
downloadupstream-17a7b9cb506ed861d9589a3a8c34c6a430b06d5a.tar.gz
upstream-17a7b9cb506ed861d9589a3a8c34c6a430b06d5a.tar.bz2
upstream-17a7b9cb506ed861d9589a3a8c34c6a430b06d5a.zip
hostapd: truncate default mac file before adding entries to it (#13797)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37114 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd.sh2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index d3447dfca0..e7150396e8 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
PKG_VERSION:=20130630
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_REV:=9e6a321815f924e1e42896538d639e62d7786f6a
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/network/services/hostapd/files/hostapd.sh b/package/network/services/hostapd/files/hostapd.sh
index 8d6f30538d..94f75c1c95 100644
--- a/package/network/services/hostapd/files/hostapd.sh
+++ b/package/network/services/hostapd/files/hostapd.sh
@@ -220,7 +220,9 @@ hostapd_set_bss_options() {
if [ -z "$macfile" ]
then
# if no macfile has been specified, fallback to the default name
+ # and truncate file to avoid aggregating entries over time
macfile="/var/run/hostapd-$ifname.maclist"
+ echo "" > "$macfile"
else
if [ -n "$maclist" ]
then