aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-01 00:31:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-01 00:31:20 +0000
commitd263077b6a6ad25cf9fb014c1701a28455884b4e (patch)
tree569e596ccb2d13eb5fde914f52599af4244b3f96 /package
parentd872db7a0e808d0e46a6bb3c8df64f9c9a31a24b (diff)
downloadupstream-d263077b6a6ad25cf9fb014c1701a28455884b4e.tar.gz
upstream-d263077b6a6ad25cf9fb014c1701a28455884b4e.tar.bz2
upstream-d263077b6a6ad25cf9fb014c1701a28455884b4e.zip
remove some debugging code, include package/rules.mk in package dependency check
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3884 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/rules.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/rules.mk b/package/rules.mk
index 61c2ae3eb0..4a8d947161 100644
--- a/package/rules.mk
+++ b/package/rules.mk
@@ -6,11 +6,11 @@ endif
define Build/DefaultTargets
ifeq ($(DUMP),)
- ifeq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . | tee /tmp/xy1),.)
+ ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(TOPDIR)/package/rules.mk),$(PKG_BUILD_DIR))
$(PKG_BUILD_DIR)/.prepared: package-clean
endif
- ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR) | tee /tmp/xy2),$(IPKG_$(1)))
+ ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
$(PKG_BUILD_DIR)/.built: package-rebuild
endif
endif