aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-20 14:32:13 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-20 14:32:13 +0000
commitd2354353d15756590133b6a8e77f8eda08ea1d9d (patch)
tree1a82879152893dbd36e290d93c4eae0d677ae3f8 /package
parent01166f129e6eec2e9d84aac102c3a0e7cae8f6f7 (diff)
downloadupstream-d2354353d15756590133b6a8e77f8eda08ea1d9d.tar.gz
upstream-d2354353d15756590133b6a8e77f8eda08ea1d9d.tar.bz2
upstream-d2354353d15756590133b6a8e77f8eda08ea1d9d.zip
make morse LED trigger available as a package, and fix it to compile with 2.6.23
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9363 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index ca454a1c6e..ba6f6f89bd 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -334,6 +334,21 @@ endef
$(eval $(call KernelPackage,leds-wrap))
+define KernelPackage/ledtrig-morse
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=LED Morse Trigger
+ KCONFIG:=CONFIG_LEDS_TRIGGER_MORSE
+ FILES:=$(LINUX_DIR)/drivers/leds/ledtrig-morse.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,ledtrig-morse)
+endef
+
+define KernelPackage/ledtrig-morse/description
+ Kernel module to show morse coded messages on LEDs.
+endef
+
+$(eval $(call KernelPackage,ledtrig-morse))
+
+
define KernelPackage/nsc-gpio
SUBMENU:=$(OTHER_MENU)
TITLE:=Natsemi GPIO support