aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 14:15:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 14:15:32 +0000
commitba1e8fb09f0b1aa96139bc7b300ddba1b2106525 (patch)
treecb0e99ab0b7339c58c266dd8a3b84c064de84fae /package
parentf0541671e43181e7d07745e2ddf6c38a9ddbf7ba (diff)
downloadupstream-ba1e8fb09f0b1aa96139bc7b300ddba1b2106525.tar.gz
upstream-ba1e8fb09f0b1aa96139bc7b300ddba1b2106525.tar.bz2
upstream-ba1e8fb09f0b1aa96139bc7b300ddba1b2106525.zip
add id3lib to sdk depends, change package compile depends
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2237 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/Makefile b/package/Makefile
index 91307cd6c3..0bddabbc81 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -206,7 +206,7 @@ package-$(BR2_PACKAGE_XINETD) += xinetd
package-$(BR2_PACKAGE_XSUPPLICANT) += xsupplicant
package-$(BR2_PACKAGE_ZLIB) += zlib
-DEV_LIBS:=tcp_wrappers glib ncurses openssl pcre popt zlib libnet libpcap mysql postgresql iptables matrixssl lzo gmp fuse portmap libelf uclibc++ speex libpng libgd wireless-tools nvram linux-atm libamsel libao libart libdaemon libdb libdnet libevent libffi-sable libgcrypt libgdbm libgpg-error libid3tag libmad libnet libnids libogg libosip2 libpcap libtasn1 libupnp libusb libvorbis libvorbisidec libxml2 libxslt
+DEV_LIBS:=tcp_wrappers glib ncurses openssl pcre popt zlib libnet libpcap mysql postgresql iptables matrixssl lzo gmp fuse portmap libelf uclibc++ speex libpng libgd wireless-tools nvram linux-atm libamsel libao libart libdaemon libdb libdnet libevent libffi-sable libgcrypt libgdbm libgpg-error libid3tag libmad libnet libnids libogg libosip2 libpcap libtasn1 libupnp libusb libvorbis libvorbisidec libxml2 libxslt id3lib
DEV_LIBS_COMPILE:=$(patsubst %,%-compile,$(DEV_LIBS))
SDK_DEFAULT_PACKAGES:=busybox dnsmasq iptables wireless-tools dropbear bridge ipkg ppp
SDK_DEFAULT_COMPILE:=$(patsubst %,%-compile,$(SDK_DEFAULT_PACKAGES))
@@ -447,11 +447,12 @@ $(TARGET_DIR):
}
@touch $(STAMP_DIR)/.$@
-%-compile: %-prepare
+%-compile:
@[ -f $(STAMP_DIR)/.$@ ] || { \
$(TRACE) package/$(patsubst %-compile,%,$@)/compile; \
$(MAKE) -C $(patsubst %-compile,%,$@) compile; \
}
+ @touch $(STAMP_DIR)/.$(patsubst %-compile,%,$@)-prepare
@touch $(STAMP_DIR)/.$@
%-install: %-compile