aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-20 07:46:00 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-20 07:46:00 +0000
commitaf1de545ab72c08bacd17053992e6f3cb86cdf57 (patch)
tree00d349673f7ae6eda1fe3465330aafa29aa9de29 /package
parenta9c1893fa75a5dcc507f5351099930966b3d0daa (diff)
downloadupstream-af1de545ab72c08bacd17053992e6f3cb86cdf57.tar.gz
upstream-af1de545ab72c08bacd17053992e6f3cb86cdf57.tar.bz2
upstream-af1de545ab72c08bacd17053992e6f3cb86cdf57.zip
disable more modules not supported on UML
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8857 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/video.mk1
-rw-r--r--package/rt2x00/Makefile2
2 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/modules/video.mk b/package/kernel/modules/video.mk
index 4a36031648..838c4c5f62 100644
--- a/package/kernel/modules/video.mk
+++ b/package/kernel/modules/video.mk
@@ -11,6 +11,7 @@ VIDEO_MENU:=Video Support
define KernelPackage/video-core
SUBMENU:=$(VIDEO_MENU)
TITLE=Video4Linux support
+ DEPENDS:= @!TARGET_uml
KCONFIG:= \
CONFIG_VIDEO_DEV \
CONFIG_VIDEO_V4L1=y \
diff --git a/package/rt2x00/Makefile b/package/rt2x00/Makefile
index 71cd418be8..9dd9286933 100644
--- a/package/rt2x00/Makefile
+++ b/package/rt2x00/Makefile
@@ -29,7 +29,7 @@ endif
define KernelPackage/rt2x00/Default
SUBMENU:=Wireless Drivers
TITLE:=Ralink Drivers for RT2x00 cards
- DEPENDS:=@LINUX_2_6 @!TARGET_atheros
+ DEPENDS:=@LINUX_2_6 @!TARGET_atheros @!TARGET_uml
KCONFIG:=CONFIG_MAC80211
endef