aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-03-08 00:21:25 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-03-08 00:21:25 +0000
commita53587df97235e13ead9020adebe2c03e7d74a9d (patch)
tree1e9fbe8bf7806aa62bf18f878ee3b210beb8cd99 /package
parent40851402212c8a7a1946eace546e431a26732409 (diff)
downloadupstream-a53587df97235e13ead9020adebe2c03e7d74a9d.tar.gz
upstream-a53587df97235e13ead9020adebe2c03e7d74a9d.tar.bz2
upstream-a53587df97235e13ead9020adebe2c03e7d74a9d.zip
[package] sysupgrade: install /bin/sleep into ramdisk too and add completition notice (#4747)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14784 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile4
-rw-r--r--package/base-files/files/lib/upgrade/common.sh3
2 files changed, 4 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 437952d72f..33e8237819 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=15
+PKG_RELEASE:=16
PKG_FILE_DEPEND:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/lib/upgrade/common.sh b/package/base-files/files/lib/upgrade/common.sh
index cf8977a5f2..d4fb04ba97 100644
--- a/package/base-files/files/lib/upgrade/common.sh
+++ b/package/base-files/files/lib/upgrade/common.sh
@@ -45,7 +45,7 @@ pivot() { # <new_root> <old_root>
}
run_ramfs() { # <command> [...]
- install_bin /bin/busybox /bin/ash /bin/sh /bin/mount /bin/umount /sbin/pivot_root /usr/bin/wget /sbin/reboot /bin/sync /bin/dd /bin/grep /bin/cp /bin/mv /bin/tar /usr/bin/md5sum "/usr/bin/[" /bin/vi /bin/ls /bin/cat /usr/bin/awk /usr/bin/hexdump
+ install_bin /bin/busybox /bin/ash /bin/sh /bin/mount /bin/umount /sbin/pivot_root /usr/bin/wget /sbin/reboot /bin/sync /bin/dd /bin/grep /bin/cp /bin/mv /bin/tar /usr/bin/md5sum "/usr/bin/[" /bin/vi /bin/ls /bin/cat /usr/bin/awk /usr/bin/hexdump /bin/sleep
install_bin /sbin/mtd
for file in $RAMFS_COPY_BIN; do
install_bin $file
@@ -160,6 +160,7 @@ do_upgrade() {
jffs2_copy_config
fi
}
+ v "Upgrade completed"
[ -n "$DELAY" ] && sleep "$DELAY"
ask_bool 1 "Reboot" && reboot
}