aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-23 19:13:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-23 19:13:08 +0000
commit9da149dc051a94bb32a41f3bd2699f7898f24265 (patch)
tree51d334bb81e3af89f8afaffeae6940043cb256bd /package
parent3438f73de218409f5b9d508f0be26655c3a9ca6b (diff)
downloadupstream-9da149dc051a94bb32a41f3bd2699f7898f24265.tar.gz
upstream-9da149dc051a94bb32a41f3bd2699f7898f24265.tar.bz2
upstream-9da149dc051a94bb32a41f3bd2699f7898f24265.zip
make busybox autorebuild on relevant config changes
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6651 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/busybox/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 3049601524..90e3af060a 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -19,6 +19,10 @@ PKG_MD5SUM:=5728403bce309cdabcffa414e2e64052
include $(INCLUDE_DIR)/package.mk
+ifeq ($(DUMP),)
+ STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell grep '^CONFIG_BUSYBOX_' $(TOPDIR)/.config | md5s)
+endif
+
init-y :=
init-$(CONFIG_BUSYBOX_CONFIG_HTTPD) += httpd
init-$(CONFIG_BUSYBOX_CONFIG_CROND) += cron
@@ -46,6 +50,7 @@ define Package/busybox/config
endef
define Build/Configure
+ rm -f $(PKG_BUILD_DIR)/.configured*
$(SCRIPT_DIR)/gen_busybox_config.pl $(TOPDIR)/.config > $(PKG_BUILD_DIR)/.config
yes '' | $(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \