aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-07-25 23:41:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-07-25 23:41:22 +0000
commit9ba812542b046099662935fca477d0690caafefb (patch)
tree8d784e3aaf5e2c2af82372c5e768b814d59b5ddd /package
parentdaf2784be5fa8093148f04aef77451704a8012fc (diff)
downloadupstream-9ba812542b046099662935fca477d0690caafefb.tar.gz
upstream-9ba812542b046099662935fca477d0690caafefb.tar.bz2
upstream-9ba812542b046099662935fca477d0690caafefb.zip
[package] add support for the sn9c102 video chips (#3976)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16991 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/video.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/modules/video.mk b/package/kernel/modules/video.mk
index 5fd008bb70..f8b7a491ca 100644
--- a/package/kernel/modules/video.mk
+++ b/package/kernel/modules/video.mk
@@ -126,6 +126,24 @@ endef
$(eval $(call KernelPackage,video-ovcamchip))
+define KernelPackage/video-sn9c102
+ SUBMENU:=$(VIDEO_MENU)
+ TITLE:=SN9C102 Camera Chip support
+ DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core +kmod-video-core
+ KCONFIG:=CONFIG_USB_SN9C102
+ FILES:=$(LINUX_DIR)/drivers/media/video/sn9c102/sn9c102.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,70,sn9c102)
+endef
+
+
+define KernelPackage/video-sn9c102/description
+ Kernel modules for supporting SN9C102
+ camera chips.
+endef
+
+$(eval $(call KernelPackage,video-sn9c102))
+
+
define KernelPackage/video-pwc
SUBMENU:=$(VIDEO_MENU)
TITLE:=Philips USB webcam support