aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-02-07 18:17:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-02-07 18:17:12 +0000
commit891d869bd603256f2fc3a695103eac1b998c472d (patch)
tree0398f3e65ed9f503fe9b918801cb67f49cb60b1d /package
parentee229f5c9cce4577151b416b36e246c33b3a2424 (diff)
downloadupstream-891d869bd603256f2fc3a695103eac1b998c472d.tar.gz
upstream-891d869bd603256f2fc3a695103eac1b998c472d.tar.bz2
upstream-891d869bd603256f2fc3a695103eac1b998c472d.zip
add libubox, a small utility library containing blob/blobmsg (structured message format libraries), uloop, usock, list.h and the olsr avl tree implementation
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25406 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/libubox/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/package/libubox/Makefile b/package/libubox/Makefile
new file mode 100644
index 0000000000..a2b3a9c51a
--- /dev/null
+++ b/package/libubox/Makefile
@@ -0,0 +1,41 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libubox
+PKG_VERSION:=2010-02-07
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://nbd.name/luci2/libubox.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=e44dbfb1029829dbd6c5e1ca11e461d9a89027b9
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+CMAKE_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/libubox
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Basic utility library
+ DEPENDS:=+libjson
+endef
+
+
+define Package/libblobmsg-json
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=blobmsg <-> json conversion library
+ DEPENDS:=+libjson
+endef
+
+
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+
+define Package/libubox/install
+ $(INSTALL_DIR) $(1)/lib/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/*.so $(1)/lib/
+endef
+
+$(eval $(call BuildPackage,libubox))
+