aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-09-02 00:52:34 +0000
committerNicolas Thill <nico@openwrt.org>2005-09-02 00:52:34 +0000
commit866ba255babbff82e7f32d9733dc582dcd5c0974 (patch)
tree4c4671b6a86e03fd2e2ce072faa5c711b37fb18a /package
parent7905dd0aaa5d5d2d3956c169563f609e505b630e (diff)
downloadupstream-866ba255babbff82e7f32d9733dc582dcd5c0974.tar.gz
upstream-866ba255babbff82e7f32d9733dc582dcd5c0974.tar.bz2
upstream-866ba255babbff82e7f32d9733dc582dcd5c0974.zip
fix building when host and target systems are same arch
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1827 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/curl/patches/500-configure_cross.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/package/curl/patches/500-configure_cross.patch b/package/curl/patches/500-configure_cross.patch
new file mode 100644
index 0000000000..7fa921c988
--- /dev/null
+++ b/package/curl/patches/500-configure_cross.patch
@@ -0,0 +1,64 @@
+diff -ruN curl-7.14.0-old/configure curl-7.14.0-new/configure
+--- curl-7.14.0-old/configure 2005-05-14 00:23:47.000000000 +0200
++++ curl-7.14.0-new/configure 2005-09-02 02:03:38.000000000 +0200
+@@ -26132,10 +26132,10 @@
+
+ fi
+
+- if test "$OPENSSL_ENABLED" = "1"; then
+- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$EXTRA_SSL/lib$libsuff"
+- export LD_LIBRARY_PATH
+- fi
++# if test "$OPENSSL_ENABLED" = "1"; then
++# LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$EXTRA_SSL/lib$libsuff"
++# export LD_LIBRARY_PATH
++# fi
+
+ fi
+
+@@ -26325,8 +26325,8 @@
+ echo "$as_me: detected GnuTLS version $version" >&6;}
+
+
+- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlsprefix/lib$libsuff"
+- export LD_LIBRARY_PATH
++# LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlsprefix/lib$libsuff"
++# export LD_LIBRARY_PATH
+ fi
+
+ fi
+diff -ruN curl-7.14.0-old/configure.ac curl-7.14.0-new/configure.ac
+--- curl-7.14.0-old/configure.ac 2005-05-13 23:19:21.000000000 +0200
++++ curl-7.14.0-new/configure.ac 2005-09-02 02:03:45.000000000 +0200
+@@ -917,13 +917,13 @@
+
+ fi
+
+- if test "$OPENSSL_ENABLED" = "1"; then
+- dnl when the ssl shared libs were found in a path that the run-time linker
+- dnl doesn't search through, we need to add it to LD_LIBRARY_PATH to
+- dnl prevent further configure tests to fail due to this
+- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$EXTRA_SSL/lib$libsuff"
+- export LD_LIBRARY_PATH
+- fi
++# if test "$OPENSSL_ENABLED" = "1"; then
++# dnl when the ssl shared libs were found in a path that the run-time linker
++# dnl doesn't search through, we need to add it to LD_LIBRARY_PATH to
++# dnl prevent further configure tests to fail due to this
++# LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$EXTRA_SSL/lib$libsuff"
++# export LD_LIBRARY_PATH
++# fi
+
+ fi
+
+@@ -1021,8 +1021,8 @@
+ dnl LD_LIBRARY_PATH to prevent further configure tests to fail
+ dnl due to this
+
+- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlsprefix/lib$libsuff"
+- export LD_LIBRARY_PATH
++# LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlsprefix/lib$libsuff"
++# export LD_LIBRARY_PATH
+ fi
+
+ fi