aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-06-29 20:48:58 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-06-29 20:48:58 +0000
commit70e74033fa86d65dfa4d222b0883fb88c1ab44ff (patch)
treeadcd4c6acf3970e929e876c05fb5096c8bfe33ed /package
parent19074c2685daab40b9cb4b9defed2dac016ce6cf (diff)
downloadupstream-70e74033fa86d65dfa4d222b0883fb88c1ab44ff.tar.gz
upstream-70e74033fa86d65dfa4d222b0883fb88c1ab44ff.tar.bz2
upstream-70e74033fa86d65dfa4d222b0883fb88c1ab44ff.zip
[package] openssl: fix bad chmod in install section (#5433)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16624 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/openssl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 3483c609d2..e6788172d1 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -130,8 +130,8 @@ endef
define Package/libopenssl/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.so.* $(1)/usr/lib/
- chmod 0644 $(1)/usr/lib/*
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libcrypto.so.* $(1)/usr/lib/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libssl.so.* $(1)/usr/lib/
endef
define Package/openssl-util/install