aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-02-05 07:57:07 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-02-05 07:57:07 +0000
commit6da72b8e02958959722d95184260bf2fc7afcd38 (patch)
tree61c31ef0614b652f217845d3a982f6b1fd063dcf /package
parentea0b97cf6820147bd2e6fa5017bd61cf969c8267 (diff)
downloadupstream-6da72b8e02958959722d95184260bf2fc7afcd38.tar.gz
upstream-6da72b8e02958959722d95184260bf2fc7afcd38.tar.bz2
upstream-6da72b8e02958959722d95184260bf2fc7afcd38.zip
[package] base-files: fix udhcpc address acquisition on network restart (patch by Scott Dudley)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19530 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/usr/share/udhcpc/default.script3
2 files changed, 3 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index ae86a89183..fa0711fe2a 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=37
+PKG_RELEASE:=38
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/usr/share/udhcpc/default.script b/package/base-files/files/usr/share/udhcpc/default.script
index b32b2c9f25..f704a7bf29 100755
--- a/package/base-files/files/usr/share/udhcpc/default.script
+++ b/package/base-files/files/usr/share/udhcpc/default.script
@@ -31,7 +31,8 @@ setup_interface () {
config_get old_subnet "$ifc" netmask
}
- [ "$ip" != "$old_ip" ] \
+ [ "$1" = "ifup" ] \
+ || [ "$ip" != "$old_ip" ] \
|| [ "${broadcast:-+}" != "$old_broadcast" ] \
|| [ "${subnet:-255.255.255.0}" != "$old_subnet" ] && {
echo "udhcpc: ifconfig $interface $ip netmask ${subnet:-255.255.255.0} broadcast ${broadcast:-+}"