aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-06-12 11:06:39 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-06-12 11:06:39 +0000
commit68f656eedae8dceb3cf2ab2ae90b61711ace4fd1 (patch)
tree78ba7e2373bf92130f3405a407588a5a9c677e4d /package
parent61178417c3e57432e927ea5914ed0ac9c2271f15 (diff)
downloadupstream-68f656eedae8dceb3cf2ab2ae90b61711ace4fd1.tar.gz
upstream-68f656eedae8dceb3cf2ab2ae90b61711ace4fd1.tar.bz2
upstream-68f656eedae8dceb3cf2ab2ae90b61711ace4fd1.zip
Package libstdc++ (#1883)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7581 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index cc6ce5d2a1..eadfb9b151 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -80,6 +80,13 @@ define Package/libssp
TITLE:=GCC support library
endef
+define Package/libstdcpp
+ $(call Package/gcc/Default)
+ NAME:=libstdc++
+ TITLE:=GNU Standard C++ Library v3
+ DEPENDS:=@!NATIVE_TOOLCHAIN&&@INSTALL_LIBSTDCPP
+endef
+
define Package/uclibc/Default
SECTION:=libs
CATEGORY:=Base system
@@ -161,6 +168,11 @@ ifeq ($(word 1,$(subst ., ,$(LIBGCC_VERSION))),4)
endef
endif
+define Package/libstdcpp/install
+ $(INSTALL_DIR) $(1)/lib
+ $(CP) $(STAGING_DIR)/lib/libstdc++.so.* $(1)/lib/
+endef
+
define Package/libpthread/install
$(INSTALL_DIR) $(1)/lib
$(CP) $(STAGING_DIR)/lib/libpthread.so.* $(1)/lib/
@@ -192,5 +204,6 @@ endif
$(eval $(call BuildPackage,base-files$(TARGET)))
$(eval $(call BuildPackage,libgcc))
$(eval $(call BuildPackage,libssp))
+$(eval $(call BuildPackage,libstdcpp))
$(eval $(call BuildPackage,libpthread))
$(eval $(call BuildPackage,uclibc))