aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-03-10 14:30:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-03-10 14:30:05 +0000
commit62574df3c8b7a391df671e7ad48fef74fd68c7a2 (patch)
treefc7ff38882744498c5917ed1f8093bdd5bc385db /package
parentdea84466ad507bcbd166eb597de2e8d8e9b0a288 (diff)
downloadupstream-62574df3c8b7a391df671e7ad48fef74fd68c7a2.tar.gz
upstream-62574df3c8b7a391df671e7ad48fef74fd68c7a2.tar.bz2
upstream-62574df3c8b7a391df671e7ad48fef74fd68c7a2.zip
[package] kernel: fix usage of CompareKernelPatchVer for kmod-gre
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26010 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/netsupport.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 8379931f1a..25e2ac42c2 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -371,11 +371,11 @@ define KernelPackage/gre
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=GRE support
KCONFIG:=CONFIG_NET_IPGRE \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),CONFIG_NET_IPGRE_DEMUX)
+ $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),CONFIG_NET_IPGRE_DEMUX)
FILES=$(LINUX_DIR)/net/ipv4/ip_gre.ko \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),$(LINUX_DIR)/net/ipv4/gre.ko)
+ $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),$(LINUX_DIR)/net/ipv4/gre.ko)
AUTOLOAD:=$(call AutoLoad,39, \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),gre) ip_gre)
+ $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),gre) ip_gre)
endef
define KernelPackage/gre/description