aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-04-27 12:57:29 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-04-27 12:57:29 +0000
commit4e5728de54de8d1536450b76cb1feb216b50c071 (patch)
tree1616eaf105d38ff779f2eead8d7406ab999d030b /package
parent5f6fe3f3fefaa7e77a1451603adebbf192db0696 (diff)
downloadupstream-4e5728de54de8d1536450b76cb1feb216b50c071.tar.gz
upstream-4e5728de54de8d1536450b76cb1feb216b50c071.tar.bz2
upstream-4e5728de54de8d1536450b76cb1feb216b50c071.zip
[package] unvram: rename executable to "nvram" and place it in /usr/sbin, add fixup init script from old nvram package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15435 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/unvram/Makefile9
-rwxr-xr-xpackage/unvram/files/nvram.init75
-rw-r--r--package/unvram/src/Makefile4
3 files changed, 83 insertions, 5 deletions
diff --git a/package/unvram/Makefile b/package/unvram/Makefile
index c62873e6fb..fa8f661756 100644
--- a/package/unvram/Makefile
+++ b/package/unvram/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=unvram
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
@@ -18,6 +18,7 @@ define Package/unvram
SECTION:=utils
CATEGORY:=Base system
TITLE:=Userspace port of the Broadcom NVRAM manipulation tool
+ DEPENDS:=@TARGET_brcm_2_4||@TARGET_brcm47xx
endef
define Package/unvram/description
@@ -41,8 +42,10 @@ define Build/Compile
endef
define Package/unvram/install
- $(INSTALL_DIR) $(1)/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/unvram $(1)/sbin/
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/nvram.init $(1)/etc/init.d/nvram
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/nvram $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/usr/lib
$(INSTALL_BIN) $(PKG_BUILD_DIR)/libnvram.so.0.1 $(1)/usr/lib/
endef
diff --git a/package/unvram/files/nvram.init b/package/unvram/files/nvram.init
new file mode 100755
index 0000000000..fcfa7f65e9
--- /dev/null
+++ b/package/unvram/files/nvram.init
@@ -0,0 +1,75 @@
+#!/bin/sh /etc/rc.common
+# NVRAM setup
+#
+# This file handles the NVRAM quirks of various hardware.
+
+START=02
+alias debug=${DEBUG:-:}
+
+nvram_default() {
+ [ -z "$(nvram get $1)" ] && nvram set "$1=$2"
+}
+
+nvram_set() { # for the linksys fixup part
+ [ "$(nvram get "$1")" = "$2" -a "$2" != "" ] || {
+ COMMIT=1
+ /usr/sbin/nvram set "$1=$2"
+ }
+}
+
+fixup_linksys() {
+ # work around braindead CFE defaults in linksys routers
+ boardtype=$(nvram get boardtype)
+ boardnum=$(nvram get boardnum)
+ boardflags=$(($(nvram get boardflags)))
+ adm_switch="$(( ($boardflags & 0x80) >> 7 ))"
+
+ [ -n "$(nvram get vxkilled)" ] && boardtype=0 # don't mess with the ram settings on the hacked cfe
+ case "$(( $boardtype ))" in
+ "1800") #0x708
+ if [ "$adm_switch" = 0 ]; then
+ nvram_set sdram_init "$(printf 0x%04x $(( $(/usr/sbin/nvram get sdram_init) | 0x0100 )))"
+ [ "$COMMIT" = 1 ] && {
+ nvram_set clkfreq 216
+ nvram_set sdram_ncdl 0x0
+ nvram_set pa0itssit 62
+ nvram_set pa0b0 0x15eb
+ nvram_set pa0b1 0xfa82
+ nvram_set pa0b2 0xfe66
+ nvram_set pa0maxpwr 0x4e
+ }
+ fi
+ ;;
+ "1127") #0x467
+ nvram_set sdram_init "$(printf 0x%04x $(( $(/usr/sbin/nvram get sdram_init) | 0x0100 )))"
+ [ "$COMMIT" = 1 ] && {
+ nvram_set sdram_ncdl 0x0
+ nvram_set pa0itssit 62
+ nvram_set pa0b0 0x168b
+ nvram_set pa0b1 0xfabf
+ nvram_set pa0b2 0xfeaf
+ nvram_set pa0maxpwr 0x4e
+ }
+ ;;
+ "1071") #0x042f
+ nvram_set sdram_init "$(printf 0x%04x $(( $(/usr/sbin/nvram get sdram_init) | 0x0009 )))"
+ [ "$COMMIT" = 1 ] && {
+ nvram_set sdram_ncdl 0x0
+ }
+ esac
+ [ "$COMMIT" = "1" ] && nvram commit
+}
+
+start() {
+ fixup_linksys
+
+ # OFDM Power Offset is set incorrectly on many boards.
+ # Setting it to 0 will increase the tx power to normal levels.
+ nvram_set opo 0x0
+
+ [ "$(nvram get il0macaddr)" = "00:90:4c:5f:00:2a" ] && {
+ # if default wifi mac, set two higher than the lan mac
+ nvram set il0macaddr=$(nvram get et0macaddr|
+ awk '{OFS=FS=":";for(x=7,y=2;--x;){$x=sprintf("%02x",(y+="0x"$x)%256);y/=256}print}')
+ }
+}
diff --git a/package/unvram/src/Makefile b/package/unvram/src/Makefile
index 7f92aa8b83..4872728baf 100644
--- a/package/unvram/src/Makefile
+++ b/package/unvram/src/Makefile
@@ -1,4 +1,4 @@
-CLI_FILENAME = unvram
+CLI_FILENAME = nvram
LIB_VERMAJOR = 0
LIB_VERMINOR = 1
@@ -30,4 +30,4 @@ libnvram:
-o $(LIB_FILENAME).$(LIB_VERMAJOR).$(LIB_VERMINOR) $(LIB_OBJ)
clean:
- rm -f nvram $(LIB_FILENAME)* *.o
+ rm -f $(CLI_FILENAME) $(LIB_FILENAME)* *.o