aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2010-03-24 00:22:19 +0000
committerTravis Kemen <thepeople@openwrt.org>2010-03-24 00:22:19 +0000
commit3f7af4ef3e946d07f3d343e4cf01bf7785b25498 (patch)
tree68354957517b81e11940ba16111c89f09672b865 /package
parent650507a240180b78b95e55110c63dca74b2af0b0 (diff)
downloadupstream-3f7af4ef3e946d07f3d343e4cf01bf7785b25498.tar.gz
upstream-3f7af4ef3e946d07f3d343e4cf01bf7785b25498.tar.bz2
upstream-3f7af4ef3e946d07f3d343e4cf01bf7785b25498.zip
Enable management frame protection in hostapd, and make it configurable
in /etc/config/wireless. Since ath9k is currently the only driver that supports MFP, it will only be enabled when ath9k is enabled. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20396 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/hostapd/Makefile3
-rw-r--r--package/hostapd/files/hostapd.sh7
2 files changed, 9 insertions, 1 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 002cd5328b..4c261f3cae 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -54,7 +54,8 @@ DRIVER_MAKEOPTS= \
CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-mac80211) \
CONFIG_DRIVER_MADWIFI=$(CONFIG_PACKAGE_kmod-madwifi) \
CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
- CONFIG_IEEE80211N=$(CONFIG_PACKAGE_kmod-ath9k)
+ CONFIG_IEEE80211N=$(CONFIG_PACKAGE_kmod-ath9k) \
+ CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
ifeq ($(LOCAL_TYPE),supplicant)
ifeq ($(LOCAL_VARIANT),full)
diff --git a/package/hostapd/files/hostapd.sh b/package/hostapd/files/hostapd.sh
index c83c06df86..78dcf82f0b 100644
--- a/package/hostapd/files/hostapd.sh
+++ b/package/hostapd/files/hostapd.sh
@@ -106,6 +106,13 @@ hostapd_set_bss_options() {
append "$var" "ssid=$ssid" "$N"
[ -n "$bridge" ] && append "$var" "bridge=$bridge" "$N"
[ -n "$ieee80211d" ] && append "$var" "ieee80211d=$ieee80211d" "$N"
+
+ [ "$wpa" -ge "2" ] && config_get ieee80211w "$vif" ieee80211w
+ case "$ieee80211w" in
+ [012])
+ append "$var" "ieee80211w=$ieee80211w" "$N"
+ ;;
+ esac
}
hostapd_setup_vif() {