aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-05 18:45:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-05 18:45:35 +0000
commit3556782b016fa23207f3114e27dc75ef464d22c8 (patch)
tree115070344bfcd6db2c8412cd58ac20c430e3c2ab /package
parent5867d95415c8eb9f63c856e0115d4c516b76978a (diff)
downloadupstream-3556782b016fa23207f3114e27dc75ef464d22c8.tar.gz
upstream-3556782b016fa23207f3114e27dc75ef464d22c8.tar.bz2
upstream-3556782b016fa23207f3114e27dc75ef464d22c8.zip
Removed redundant '-r' flags for cp. Fixes compilation on BSD/Darwin.
$(CP) is defined as CP:="cp -fpR" Signed-off-by: Andy Boyett <agb-openwrt@padded-cell.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9661 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/fonera-mp3-drv/Makefile2
-rw-r--r--package/libjson-c/Makefile6
-rw-r--r--package/rt2x00/Makefile2
3 files changed, 5 insertions, 5 deletions
diff --git a/package/fonera-mp3-drv/Makefile b/package/fonera-mp3-drv/Makefile
index 94c19f42c2..e0c4d45088 100644
--- a/package/fonera-mp3-drv/Makefile
+++ b/package/fonera-mp3-drv/Makefile
@@ -30,7 +30,7 @@ endef
define Build/Prepare
$(call Build/Prepare/Default)
- $(CP) -r src/* $(PKG_BUILD_DIR)/
+ $(CP) src/* $(PKG_BUILD_DIR)/
endef
define Build/Compile
diff --git a/package/libjson-c/Makefile b/package/libjson-c/Makefile
index 01116aaf63..bcb298418d 100644
--- a/package/libjson-c/Makefile
+++ b/package/libjson-c/Makefile
@@ -37,11 +37,11 @@ endef
define Build/InstallDev
mkdir -p $(1)/usr/include
- $(CP) -r $(PKG_INSTALL_DIR)/usr/include/json $(1)/usr/include/
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/json $(1)/usr/include/
mkdir -p $(1)/usr/lib
- $(CP) -r $(PKG_INSTALL_DIR)/usr/lib/libjson.{a,so*} $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson.{a,so*} $(1)/usr/lib/
mkdir -p $(1)/usr/lib/pkgconfig
- $(CP) -r $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/json.pc $(1)/usr/lib/pkgconfig/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/json.pc $(1)/usr/lib/pkgconfig/
endef
define Build/UninstallDev
diff --git a/package/rt2x00/Makefile b/package/rt2x00/Makefile
index b250f1f62b..4d63963bc8 100644
--- a/package/rt2x00/Makefile
+++ b/package/rt2x00/Makefile
@@ -139,7 +139,7 @@ PKG_EXTRA_CFLAGS:= \
define Build/Prepare
$(call Build/Prepare/Default)
- $(CP) -r src/* $(PKG_BUILD_DIR)/
+ $(CP) src/* $(PKG_BUILD_DIR)/
unzip -jod $(PKG_BUILD_DIR) $(DL_DIR)/$(RT61FW)
unzip -jod $(PKG_BUILD_DIR) $(DL_DIR)/$(RT71FW)
endef