aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-10-03 23:51:10 +0000
committerNicolas Thill <nico@openwrt.org>2009-10-03 23:51:10 +0000
commit15a54116650a302bbb3c1ac0c72bb830a3a9c032 (patch)
treef601d4a279252ccd44a732bed871dc3d590be61a /package
parent288135971920592d9b3bc7c22c080fe43d88cdd4 (diff)
downloadupstream-15a54116650a302bbb3c1ac0c72bb830a3a9c032.tar.gz
upstream-15a54116650a302bbb3c1ac0c72bb830a3a9c032.tar.bz2
upstream-15a54116650a302bbb3c1ac0c72bb830a3a9c032.zip
remove ipset support from core, it is now provided by xtables-addons from the packages feed
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17844 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/ipset/Makefile48
-rw-r--r--package/iptables/Makefile6
-rw-r--r--package/kernel/modules/netfilter.mk31
3 files changed, 0 insertions, 85 deletions
diff --git a/package/ipset/Makefile b/package/ipset/Makefile
deleted file mode 100644
index b7b4a317d1..0000000000
--- a/package/ipset/Makefile
+++ /dev/null
@@ -1,48 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=ipset
-PKG_VERSION:=3.2
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://ipset.netfilter.org
-PKG_MD5SUM:=0fd83af3efae5f72f5e5b55d07582941
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/ipset
- SECTION:=net
- CATEGORY:=Network
- DEPENDS:=@!TARGET_etrax @LINUX_2_6
- TITLE:=Netfilter ip sets administration utility
- URL:=http://ipset.netfilter.org/
-endef
-
-define Build/Compile
- $(call Build/Compile/Default, \
- COPT_FLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="-rdynamic -static-libgcc" \
- KERNEL_DIR="$(LINUX_DIR)" \
- PREFIX="/usr" \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- binaries \
- )
-endef
-
-define Package/ipset/install
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(1)" \
- PREFIX="/usr" \
- binaries_install
- rm -rf $(1)/usr/man
-endef
-
-$(eval $(call BuildPackage,ipset))
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index b8164458ee..573579ab00 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -207,11 +207,6 @@ define Package/iptables-mod-extra/description
- libipt_NOTRACK
endef
-define Package/iptables-mod-ipset
-$(call Package/iptables/Module, +kmod-ipt-ipset)
- TITLE:=IPset extension
-endef
-
define Package/iptables-utils
$(call Package/iptables/Module, )
TITLE:=iptables save and restore utilities
@@ -365,7 +360,6 @@ $(eval $(call BuildPackage,iptables-utils))
$(eval $(call BuildPlugin,iptables-mod-conntrack,$(IPT_CONNTRACK-m)))
$(eval $(call BuildPlugin,iptables-mod-conntrack-extra,$(IPT_CONNTRACK_EXTRA-m)))
$(eval $(call BuildPlugin,iptables-mod-extra,$(IPT_EXTRA-m)))
-$(eval $(call BuildPlugin,iptables-mod-ipset,$(IPT_IPSET-m)))
$(eval $(call BuildPlugin,iptables-mod-filter,$(IPT_FILTER-m),$(L7_INSTALL)))
$(eval $(call BuildPlugin,iptables-mod-imq,$(IPT_IMQ-m)))
$(eval $(call BuildPlugin,iptables-mod-ipopt,$(IPT_IPOPT-m)))
diff --git a/package/kernel/modules/netfilter.mk b/package/kernel/modules/netfilter.mk
index a6988acf04..9c97379abd 100644
--- a/package/kernel/modules/netfilter.mk
+++ b/package/kernel/modules/netfilter.mk
@@ -300,37 +300,6 @@ endef
$(eval $(call KernelPackage,ipt-iprange))
-define KernelPackage/ipt-ipset
- SUBMENU:=$(NF_MENU)
- TITLE:=IPSET Modules
- KCONFIG:=$(KCONFIG_IPT_IPSET)
- FILES:=$(foreach mod,$(IPT_IPSET-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
- AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_IPSET-m)))
- DEPENDS:= kmod-ipt-core
-endef
-
-define KernelPackage/ipt-ipset/description
- Netfilter kernel modules for ipset
- Includes:
- - ip_set
- - ip_set_iphash
- - ip_set_ipmap
- - ip_set_ipporthash
- - ip_set_ipportiphash
- - ip_set_ipportnethash
- - ip_set_iptree
- - ip_set_iptreemap
- - ip_set_macipmap
- - ip_set_nethash
- - ip_set_portmap
- - ip_set_setlist
- - ipt_set
- - ipt_SET
-endef
-
-$(eval $(call KernelPackage,ipt-ipset))
-
-
define KernelPackage/ipt-extra
SUBMENU:=$(NF_MENU)
TITLE:=Extra modules