aboutsummaryrefslogtreecommitdiffstats
path: root/package/zram-swap/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2013-01-06 16:21:29 +0000
committerHauke Mehrtens <hauke@openwrt.org>2013-01-06 16:21:29 +0000
commit71830c60f7dbf02b8be097ddfc942e01dc4fb0e4 (patch)
treec8f83b7a719fb7d168480afea6939577d79af1ff /package/zram-swap/Makefile
parent009b82e8ef3dedb2ff0534e2219f5b137a5da2b6 (diff)
downloadupstream-71830c60f7dbf02b8be097ddfc942e01dc4fb0e4.tar.gz
upstream-71830c60f7dbf02b8be097ddfc942e01dc4fb0e4.tar.bz2
upstream-71830c60f7dbf02b8be097ddfc942e01dc4fb0e4.zip
zram: add package to use compressed ram disk for swap
The busybox size is increased by 3.2KByte uncompressed on bcm47xx with this commit. This zram-swap automatically creates a zram device, a swap partition on it and make the kernel swap pages to it. Thank you Bastian Bittorf <bittorf@bluebottle.com> for idea and the script. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35025 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/zram-swap/Makefile')
-rw-r--r--package/zram-swap/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/package/zram-swap/Makefile b/package/zram-swap/Makefile
new file mode 100644
index 0000000000..59a55c4776
--- /dev/null
+++ b/package/zram-swap/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=zram-swap
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/zram-swap
+ SECTION:=utils
+ CATEGORY:=Base system
+ DEPENDS:=+kmod-zram +!(BUSYBOX_CONFIG_MKSWAP&&BUSYBOX_CONFIG_SWAPONOFF):swap-utils
+ TITLE:=ZRAM swap scripts
+ PKGARCH:=all
+endef
+
+define Package/zram-swap/description
+ A script to activate swaping on a compressed zram partition. This
+ could be used to increase the available memory, by using compressed
+ memory.
+endef
+
+define Build/Prepare
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/zram-swap/install
+ $(INSTALL_DIR) $(1)
+ $(CP) ./files/* $(1)/
+endef
+
+$(eval $(call BuildPackage,zram-swap))