aboutsummaryrefslogtreecommitdiffstats
path: root/package/zlib
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-08-01 12:32:53 +0000
committerNicolas Thill <nico@openwrt.org>2007-08-01 12:32:53 +0000
commitff7008b0c181d247109de1d537acedf9f8490d14 (patch)
tree87b6a23d79a232628e7b31f936caa21d31d4e376 /package/zlib
parent8d97d41237054d664e41ad8fb2ee50a7fd3d6b91 (diff)
downloadupstream-ff7008b0c181d247109de1d537acedf9f8490d14.tar.gz
upstream-ff7008b0c181d247109de1d537acedf9f8490d14.tar.bz2
upstream-ff7008b0c181d247109de1d537acedf9f8490d14.zip
fix openssl with zlib-dynamic (closes: #1182), bump release number
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8299 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/zlib')
-rw-r--r--package/zlib/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/zlib/Makefile b/package/zlib/Makefile
index 066a399789..15407d5a3f 100644
--- a/package/zlib/Makefile
+++ b/package/zlib/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=zlib
PKG_VERSION:=1.2.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.zlib.net @SF/zlib
@@ -62,8 +62,10 @@ define Build/UninstallDev
$(STAGING_DIR)/usr/lib/libz.{a,so*}
endef
+# libz.so is needed for openssl (zlib-dynamic)
define Package/zlib/install
$(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libz.so $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libz.so.* $(1)/usr/lib/
endef