aboutsummaryrefslogtreecommitdiffstats
path: root/package/zlib
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-09-23 13:31:54 +0000
committerNicolas Thill <nico@openwrt.org>2006-09-23 13:31:54 +0000
commitd57219e7657b10c250750a764ab30828eed4304f (patch)
treee53b5ad353ec17ac755e47e099d5f8b9583f725f /package/zlib
parentf071fb6f3af44667d4842e681a52db8115beac0a (diff)
downloadupstream-d57219e7657b10c250750a764ab30828eed4304f.tar.gz
upstream-d57219e7657b10c250750a764ab30828eed4304f.tar.bz2
upstream-d57219e7657b10c250750a764ab30828eed4304f.zip
standardize Makefile, remove dup description
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4816 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/zlib')
-rw-r--r--package/zlib/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/package/zlib/Makefile b/package/zlib/Makefile
index 41be6cc830..681af85c74 100644
--- a/package/zlib/Makefile
+++ b/package/zlib/Makefile
@@ -23,11 +23,10 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/zlib
-SECTION:=base
-CATEGORY:=Libraries
-TITLE:=Library implementing the deflate compression method
-DESCRIPTION:=A library implementing the 'deflate' compression method
-URL:=http://www.zlib.net/
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Library implementing the deflate compression method
+ URL:=http://www.zlib.net/
endef
define Build/Configure
@@ -36,8 +35,8 @@ define Build/Configure
LDSHARED="$(TARGET_CC) -shared -Wl,-soname,libz.so.1" \
CFLAGS="$(TARGET_CFLAGS) $(CFLAGS_LARGEFILE)" \
./configure \
- --prefix=/usr \
- --shared \
+ --prefix=/usr \
+ --shared \
);
endef
@@ -62,12 +61,13 @@ define Build/InstallDev
endef
define Build/UninstallDev
- rm -rf $(STAGING_DIR)/usr/include/z{conf,lib}.h \
+ rm -rf \
+ $(STAGING_DIR)/usr/include/z{conf,lib}.h \
$(STAGING_DIR)/usr/lib/libz.{a,so*}
endef
define Package/zlib/install
- install -m0755 -d $(1)/usr/lib
+ install -d -m0755 $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libz.so.* $(1)/usr/lib/
endef