aboutsummaryrefslogtreecommitdiffstats
path: root/package/zlib
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-09-07 10:00:34 +0000
committerMichael Büsch <mb@bu3sch.de>2010-09-07 10:00:34 +0000
commit48db317d21b3cd54c9162e9e9c9248643f3356f0 (patch)
tree5dadc86ab8f196d7ee7d84f83407b28befc254cf /package/zlib
parentac52578132d05373a148bc7c98e16015f495fac2 (diff)
downloadupstream-48db317d21b3cd54c9162e9e9c9248643f3356f0.tar.gz
upstream-48db317d21b3cd54c9162e9e9c9248643f3356f0.tar.bz2
upstream-48db317d21b3cd54c9162e9e9c9248643f3356f0.zip
From: Joseph Roback <openwrt-devel@roback.cc>
26 Makefile patches for enabling parallel builds. Tested on Linux (8-core) and Darwin (12-core), individually and from clean build_root. The first set is from trunk, the second is from feeds/packages. Signed-off-by: Joe Roback <joe@roback.cc> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22965 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/zlib')
-rw-r--r--package/zlib/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/zlib/Makefile b/package/zlib/Makefile
index c6a18378dc..bcd6ae040a 100644
--- a/package/zlib/Makefile
+++ b/package/zlib/Makefile
@@ -15,6 +15,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.zlib.net @SF/libpng
PKG_MD5SUM:=dee233bf288ee795ac96a98cc2e369b6
+PKG_BUILD_PARALLEL:=1
+
include $(INCLUDE_DIR)/package.mk
define Package/zlib
@@ -37,7 +39,7 @@ define Build/Configure
endef
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
LDSHARED="$(TARGET_CROSS)ld -shared" \
CFLAGS="$(TARGET_CFLAGS) $(FPIC)" \