aboutsummaryrefslogtreecommitdiffstats
path: root/package/wprobe
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-29 05:01:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-29 05:01:25 +0000
commitcc3a45243ee4c653e85f16a91d9a7c31c7c35d9f (patch)
treeacc4a647572536b1001f57395810affc6f915e53 /package/wprobe
parent8dce7522b3599dff32d9955ed18e91fb3c39fc8a (diff)
downloadupstream-cc3a45243ee4c653e85f16a91d9a7c31c7c35d9f.tar.gz
upstream-cc3a45243ee4c653e85f16a91d9a7c31c7c35d9f.tar.bz2
upstream-cc3a45243ee4c653e85f16a91d9a7c31c7c35d9f.zip
wprobe: add init script for exporter
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15066 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/wprobe')
-rw-r--r--package/wprobe/Makefile3
-rwxr-xr-xpackage/wprobe/files/wprobe.init46
2 files changed, 48 insertions, 1 deletions
diff --git a/package/wprobe/Makefile b/package/wprobe/Makefile
index 89f0450f02..7fccaa2baf 100644
--- a/package/wprobe/Makefile
+++ b/package/wprobe/Makefile
@@ -103,7 +103,8 @@ define Package/wprobe-info/install
endef
define Package/wprobe-export/install
- $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_DIR) $(1)/sbin $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/wprobe.init $(1)/etc/init.d/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/exporter/wprobe-export $(1)/sbin/
endef
diff --git a/package/wprobe/files/wprobe.init b/package/wprobe/files/wprobe.init
new file mode 100755
index 0000000000..3c62a03066
--- /dev/null
+++ b/package/wprobe/files/wprobe.init
@@ -0,0 +1,46 @@
+#!/bin/sh /etc/rc.common
+START=90
+
+wprobe_ssd() {
+ local cfg="$1"; shift
+ local cmd="$1"; shift
+ start-stop-daemon "$cmd" -p "/var/run/wprobe-$cfg.pid" -b -x /sbin/wprobe-export -m -- "$@"
+}
+
+stop_wprobe() {
+ local cfg="$1"
+ [ -f "/var/run/wprobe-$cfg.pid" ] && wprobe_ssd "$cfg" -K
+ rm -f "/var/run/wprobe-$cfg.pid"
+}
+
+start_wprobe() {
+ local cfg="$1"
+ config_get ifname "$cfg" interface
+ config_get host "$cfg" host
+ config_get port "$cfg" port
+ config_get proto "$cfg" proto
+ case "$proto" in
+ sctp) proto="-s";;
+ tcp) proto="-t";;
+ udp) proto="-u";;
+ *) proto="-t";;
+ esac
+ [ -z "$ifname" -o -z "$host" ] && {
+ echo "wprobe-export: missing host or interface name in config $cfg"
+ return
+ }
+ wprobe_ssd "$cfg" -S "$proto" -i "$ifname" -c "$host" -p "${port:-4739}"
+}
+
+stop() {
+ for f in /var/run/wprobe-*.pid; do
+ CFG="${f%%.pid}"
+ CFG="${CFG##/var/run/wprobe-}"
+ stop_wprobe "$CFG"
+ done
+}
+
+start() {
+ config_load wprobe
+ config_foreach start_wprobe wprobe
+}