aboutsummaryrefslogtreecommitdiffstats
path: root/package/wprobe/src/user/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-07 12:50:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-07 12:50:15 +0000
commitfafaa38ae55cab486f2b929a131fe433ce180224 (patch)
tree25d7e19e357623b44714e2052228a7e05eb3ade7 /package/wprobe/src/user/Makefile
parent6f752c725a5b592dff8c17f0fe4e905de22b8112 (diff)
downloadupstream-fafaa38ae55cab486f2b929a131fe433ce180224.tar.gz
upstream-fafaa38ae55cab486f2b929a131fe433ce180224.tar.bz2
upstream-fafaa38ae55cab486f2b929a131fe433ce180224.zip
move a few unmaintained packages from trunk to /packages
SVN-Revision: 33634
Diffstat (limited to 'package/wprobe/src/user/Makefile')
-rw-r--r--package/wprobe/src/user/Makefile38
1 files changed, 0 insertions, 38 deletions
diff --git a/package/wprobe/src/user/Makefile b/package/wprobe/src/user/Makefile
deleted file mode 100644
index 01e83da3eb..0000000000
--- a/package/wprobe/src/user/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-include ../Makefile.inc
-
-CPPFLAGS += -I../kernel
-LDFLAGS =
-
-ifneq ($(HOST_OS),Linux)
-USE_LIBNL_MICRO=1
-else
-USE_LIBNL_MICRO=
-endif
-
-ifeq ($(USE_LIBNL_MICRO),1)
-LIBNL_PREFIX = /usr/local
-LIBNL = $(LIBNL_PREFIX)/lib/libnl-micro.a
-CPPFLAGS += -I$(LIBNL_PREFIX)/include/libnl-micro
-EXTRA_CFLAGS += -DNO_LOCAL_ACCESS
-else
-LIBNL = -lnl
-endif
-
-LIBM = -lm
-LIBS = $(LIBNL) $(LIBM)
-
-all: libwprobe.a wprobe-util
-
-libwprobe.a: wprobe-lib.o
- rm -f $@
- $(AR) rcu $@ $^
- $(RANLIB) $@
-
-%.o: %.c
- $(CC) $(WFLAGS) -c -o $@ $(CPPFLAGS) $(CFLAGS) $(EXTRA_CFLAGS) $<
-
-wprobe-util: wprobe-util.o wprobe-lib.o
- $(CC) -o $@ $^ $(LDFLAGS) $(LIBS)
-
-clean:
- rm -f *.o *.a wprobe-util