aboutsummaryrefslogtreecommitdiffstats
path: root/package/wpa_supplicant
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-04-27 15:53:00 +0000
committerNicolas Thill <nico@openwrt.org>2009-04-27 15:53:00 +0000
commit7658ef1316a0ddd0683583ca1a5978b1da4d6917 (patch)
treeb3d4b16923c5612599607d55a521d09b723cdcc9 /package/wpa_supplicant
parent9f627dbf6e018c2c61ea3254b4ab9d80ae70c213 (diff)
downloadupstream-7658ef1316a0ddd0683583ca1a5978b1da4d6917.tar.gz
upstream-7658ef1316a0ddd0683583ca1a5978b1da4d6917.tar.bz2
upstream-7658ef1316a0ddd0683583ca1a5978b1da4d6917.zip
introduce a generic PKG_CONFIG_DEPENDS for packages that need to be reconfigured when certain CONFIG options changed, rename PKG_BUILD_DEPEND to PKG_BUILD_DEPENDS
SVN-Revision: 15451
Diffstat (limited to 'package/wpa_supplicant')
-rw-r--r--package/wpa_supplicant/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/package/wpa_supplicant/Makefile b/package/wpa_supplicant/Makefile
index 0ad2ff31f8..de1a0a476a 100644
--- a/package/wpa_supplicant/Makefile
+++ b/package/wpa_supplicant/Makefile
@@ -15,10 +15,14 @@ PKG_MD5SUM:=0efb8fcedf0a8acf6f423dfdb0658fdd
PKG_SOURCE_URL:=http://hostap.epitest.fi/releases
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DEPENDS:=PACKAGE_kmod-madwifi:madwifi
+PKG_BUILD_DEPENDS:= \
+ PACKAGE_kmod-madwifi:madwifi \
+
+PKG_CONFIG_DEPENDS:= \
+ CONFIG_PACKAGE_kmod-madwifi \
+ CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK \
include $(INCLUDE_DIR)/package.mk
-STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,CONFIG_PACKAGE_kmod-madwifi CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK)
define Package/wpa-supplicant
SECTION:=net