aboutsummaryrefslogtreecommitdiffstats
path: root/package/wpa_supplicant
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-09-16 10:32:42 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-09-16 10:32:42 +0000
commitb1b932e43fbf5344bb115eeb7bce56f9ed5c9e6c (patch)
treed1b9244b6dde7607e9ae4b07b4e32fa69e0e475d /package/wpa_supplicant
parent1192538019c7218407363d4460c7f00fdff90f0a (diff)
downloadupstream-b1b932e43fbf5344bb115eeb7bce56f9ed5c9e6c.tar.gz
upstream-b1b932e43fbf5344bb115eeb7bce56f9ed5c9e6c.tar.bz2
upstream-b1b932e43fbf5344bb115eeb7bce56f9ed5c9e6c.zip
Package wpa-passphrase (#1275)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8788 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/wpa_supplicant')
-rw-r--r--package/wpa_supplicant/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/package/wpa_supplicant/Makefile b/package/wpa_supplicant/Makefile
index 6448145565..a90196868c 100644
--- a/package/wpa_supplicant/Makefile
+++ b/package/wpa_supplicant/Makefile
@@ -27,7 +27,6 @@ define Package/wpa-supplicant
URL:=http://hostap.epitest.fi/wpa_supplicant/
endef
-
define Package/wpa-cli
SECTION:=net
CATEGORY:=Network
@@ -36,6 +35,13 @@ define Package/wpa-cli
DESCRIPTION:=
endef
+define Package/wpa-passphrase
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=wpa-supplicant
+ TITLE:=Set WPA passphrase for a SSID
+ DESCRIPTION:=
+endef
define Build/Configure
cp ./files/config.$(ARCH) $(PKG_BUILD_DIR)/.config
@@ -65,5 +71,11 @@ define Package/wpa-cli/install
$(CP) $(PKG_BUILD_DIR)/wpa_cli $(1)/usr/sbin/
endef
+define Package/wpa-passphrase/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wpa_passphrase $(1)/usr/sbin/
+endef
+
$(eval $(call BuildPackage,wpa-supplicant))
$(eval $(call BuildPackage,wpa-cli))
+$(eval $(call BuildPackage,wpa-passphrase))