aboutsummaryrefslogtreecommitdiffstats
path: root/package/wpa_supplicant
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-05-30 21:48:54 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-05-30 21:48:54 +0000
commitfdfea08c651989bd96d5e8a1b1f57a6ff4fac0be (patch)
tree20fe193ab0b6ceeb6f386692c0198e25d690fc6f /package/wpa_supplicant
parent95a55058f6a3c39c54ab2c4bc4f350103fb010de (diff)
downloadupstream-fdfea08c651989bd96d5e8a1b1f57a6ff4fac0be.tar.gz
upstream-fdfea08c651989bd96d5e8a1b1f57a6ff4fac0be.tar.bz2
upstream-fdfea08c651989bd96d5e8a1b1f57a6ff4fac0be.zip
[OpenWrt-Devel] [PATCH] [hostap-driver] Major enhancement to hostap.sh script
* use common openwrt option naming (e.g. sta instead of manged for mode) * add support for wds vifs * add support for monitor mode * add encryption support * add antenna selection options * add hidden ssid option * other minor fixes Signed-off-by: Vasilis Tsiligiannis <b_tsiligiannis@silverton.gr> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16220 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/wpa_supplicant')
-rw-r--r--package/wpa_supplicant/Makefile1
-rw-r--r--package/wpa_supplicant/config2
2 files changed, 2 insertions, 1 deletions
diff --git a/package/wpa_supplicant/Makefile b/package/wpa_supplicant/Makefile
index de1a0a476a..9c541551d9 100644
--- a/package/wpa_supplicant/Makefile
+++ b/package/wpa_supplicant/Makefile
@@ -57,6 +57,7 @@ TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/madwifi $(if $(CONFIG_WPA_SUPPLICA
define Build/Configure
cp $(CONFIG) $(PKG_BUILD_DIR)/wpa_supplicant/.config
$(if $(CONFIG_PACKAGE_kmod-madwifi),,$(SED) 's,^CONFIG_DRIVER_MADWIFI,#CONFIG_DRIVER_MADWIFI,g' $(PKG_BUILD_DIR)/wpa_supplicant/.config)
+ $(if $(CONFIG_PACKAGE_kmod-hostap),,$(SED) 's,^CONFIG_DRIVER_HOSTAP,#CONFIG_DRIVER_HOSTAP,g' $(PKG_BUILD_DIR)/wpa_supplicant/.config)
$(if $(CONFIG_WPA_SUPPLICANT_OPENSSL),$(SED) 's|^CONFIG_TLS.*|CONFIG_TLS=openssl|g' $(PKG_BUILD_DIR)/wpa_supplicant/.config)
endef
diff --git a/package/wpa_supplicant/config b/package/wpa_supplicant/config
index a7283fc484..3ca1cfa655 100644
--- a/package/wpa_supplicant/config
+++ b/package/wpa_supplicant/config
@@ -41,7 +41,7 @@
# Driver interface for Host AP driver
-#CONFIG_DRIVER_HOSTAP=y
+CONFIG_DRIVER_HOSTAP=y
# Driver interface for Agere driver
#CONFIG_DRIVER_HERMES=y