aboutsummaryrefslogtreecommitdiffstats
path: root/package/wpa_supplicant/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-10-18 20:51:21 +0000
committerJohn Crispin <john@openwrt.org>2007-10-18 20:51:21 +0000
commit78edb9c7bbd98454289a9a299e2aebb63840840b (patch)
treec8028209e01232ce5a064a9db463d2ccfd09ee9d /package/wpa_supplicant/Makefile
parent9b467b5b2815efe11e0d0951c8175040c86a13e5 (diff)
downloadupstream-78edb9c7bbd98454289a9a299e2aebb63840840b.tar.gz
upstream-78edb9c7bbd98454289a9a299e2aebb63840840b.tar.bz2
upstream-78edb9c7bbd98454289a9a299e2aebb63840840b.zip
fixed wpa2 support for madwifi/wpa_supplicant
SVN-Revision: 9355
Diffstat (limited to 'package/wpa_supplicant/Makefile')
-rw-r--r--package/wpa_supplicant/Makefile19
1 files changed, 1 insertions, 18 deletions
diff --git a/package/wpa_supplicant/Makefile b/package/wpa_supplicant/Makefile
index 1f798d27fe..a745313dac 100644
--- a/package/wpa_supplicant/Makefile
+++ b/package/wpa_supplicant/Makefile
@@ -41,17 +41,6 @@ define Package/wpa-cli/Description
endef
-define Package/wpa-passphrase
- SECTION:=net
- CATEGORY:=Network
- DEPENDS:=wpa-supplicant
- TITLE:=Set WPA passphrase for a SSID
-endef
-
-define Package/wpa-passphrase/Description
-
-endef
-
define Build/Configure
cp ./files/config.$(ARCH) $(PKG_BUILD_DIR)/.config
endef
@@ -72,7 +61,7 @@ endef
define Package/wpa-supplicant/install
$(INSTALL_DIR) $(1)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/wpa_supplicant $(1)/usr/sbin/
+ $(CP) $(PKG_BUILD_DIR)/wpa_{supplicant,passphrase} $(1)/usr/sbin/
endef
define Package/wpa-cli/install
@@ -80,11 +69,5 @@ define Package/wpa-cli/install
$(CP) $(PKG_BUILD_DIR)/wpa_cli $(1)/usr/sbin/
endef
-define Package/wpa-passphrase/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/wpa_passphrase $(1)/usr/sbin/
-endef
-
$(eval $(call BuildPackage,wpa-supplicant))
$(eval $(call BuildPackage,wpa-cli))
-$(eval $(call BuildPackage,wpa-passphrase))