aboutsummaryrefslogtreecommitdiffstats
path: root/package/wpa_supplicant/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-23 06:43:34 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-23 06:43:34 +0000
commitf5e2125a226494f7560c29c3353f0a8df00f8d4c (patch)
treef7cbced8dce3664bd18bde43c65897a353b82692 /package/wpa_supplicant/Makefile
parent7aea4fc0fba830ccd6c8d01a2961dbb947e63928 (diff)
downloadupstream-f5e2125a226494f7560c29c3353f0a8df00f8d4c.tar.gz
upstream-f5e2125a226494f7560c29c3353f0a8df00f8d4c.tar.bz2
upstream-f5e2125a226494f7560c29c3353f0a8df00f8d4c.zip
Add wpa_supplicant package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1023 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/wpa_supplicant/Makefile')
-rw-r--r--package/wpa_supplicant/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/package/wpa_supplicant/Makefile b/package/wpa_supplicant/Makefile
new file mode 100644
index 0000000000..3536508a70
--- /dev/null
+++ b/package/wpa_supplicant/Makefile
@@ -0,0 +1,40 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wpa_supplicant
+PKG_VERSION:=0.3.8
+PKG_RELEASE:=1
+PKG_MD5SUM:=
+
+PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,WPA_SUPPLICANT,wpa-supplicant,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ cp -fp ./files/config $(PKG_BUILD_DIR)/.config
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ CPPFLAGS="-I$(TOPDIR)/package/openwrt/include -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+ LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+ OPT_FLAGS="$(TARGET_CFLAGS)" \
+ KERNEL=$(LINUX_DIR) \
+ all
+ touch $@
+
+$(IPKG_WPA_SUPPLICANT):
+ install -m0755 -d $(IDIR_WPA_SUPPLICANT)/usr/sbin
+ install -m0755 $(PKG_BUILD_DIR)/wpa_cli $(IDIR_WPA_SUPPLICANT)/usr/sbin/
+ install -m0755 $(PKG_BUILD_DIR)/wpa_passphrase $(IDIR_WPA_SUPPLICANT)/usr/sbin/
+ install -m0755 $(PKG_BUILD_DIR)/wpa_supplicant $(IDIR_WPA_SUPPLICANT)/usr/sbin/
+ $(RSTRIP) $(IDIR_WPA_SUPPLICANT)
+ $(IPKG_BUILD) $(IDIR_WPA_SUPPLICANT) $(PACKAGE_DIR)