aboutsummaryrefslogtreecommitdiffstats
path: root/package/wireless-tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-05-30 20:47:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-05-30 20:47:25 +0000
commite96be354c139420a93b6b65e2a41e0f34925e6a5 (patch)
treea5f537e402d2f99ecf925fc07b046aff0c37b703 /package/wireless-tools
parentc9ca54f51a8f222b12f49744d9e7498ff33e7e7c (diff)
downloadupstream-e96be354c139420a93b6b65e2a41e0f34925e6a5.tar.gz
upstream-e96be354c139420a93b6b65e2a41e0f34925e6a5.tar.bz2
upstream-e96be354c139420a93b6b65e2a41e0f34925e6a5.zip
make wireless-tools install headers and library into the staging dir
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1114 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/wireless-tools')
-rw-r--r--package/wireless-tools/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/wireless-tools/Makefile b/package/wireless-tools/Makefile
index fe83163ccd..4d132b99dd 100644
--- a/package/wireless-tools/Makefile
+++ b/package/wireless-tools/Makefile
@@ -40,3 +40,16 @@ $(IPKG_WIRELESS_TOOLS):
cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/iw{config,getid,list,priv,spy} $(IDIR_WIRELESS_TOOLS)/usr/sbin/
$(RSTRIP) $(IDIR_WIRELESS_TOOLS)
$(IPKG_BUILD) $(IDIR_WIRELESS_TOOLS) $(PACKAGE_DIR)
+
+install-dev:
+ mkdir -p $(STAGING_DIR)/usr/{lib,include}
+ cp -a $(PKG_BUILD_DIR)/libiw.so* $(STAGING_DIR)/usr/lib/
+ ln -sf libiw.so.28 $(STAGING_DIR)/usr/lib/libiw.so
+ cp -a $(PKG_BUILD_DIR)/{iwlib,wireless}.h $(STAGING_DIR)/usr/include/
+
+uninstall-dev:
+ rm -f $(STAGING_DIR)/usr/lib/libiw.*
+ rm -f $(STAGING_DIR)/usr/include/{iwlib,wireless}.h
+
+compile: install-dev
+clean: uninstall-dev