aboutsummaryrefslogtreecommitdiffstats
path: root/package/wireless-tools
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-04-14 02:06:35 +0000
committerNicolas Thill <nico@openwrt.org>2008-04-14 02:06:35 +0000
commitd744030c6237e05026c4ffdcee6e0a3489609190 (patch)
tree840d034543802a8399a24929956e71457a954534 /package/wireless-tools
parent6e64b74230c2fd4fb944de084b712f351e14830f (diff)
downloadupstream-d744030c6237e05026c4ffdcee6e0a3489609190.tar.gz
upstream-d744030c6237e05026c4ffdcee6e0a3489609190.tar.bz2
upstream-d744030c6237e05026c4ffdcee6e0a3489609190.zip
package shared library as well (partially closes: #3030)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10829 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/wireless-tools')
-rw-r--r--package/wireless-tools/Makefile26
1 files changed, 24 insertions, 2 deletions
diff --git a/package/wireless-tools/Makefile b/package/wireless-tools/Makefile
index ff16c065c6..ceae0f1f8a 100644
--- a/package/wireless-tools/Makefile
+++ b/package/wireless-tools/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -22,11 +22,15 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/wireless_tools.$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
+define Package/wireless-tools/Default
+ URL:=http://hplabs.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html
+endef
+
define Package/wireless-tools
+$(call Package/wireless-tools/Default)
SECTION:=net
CATEGORY:=Base system
TITLE:=Tools for manipulating Linux Wireless Extensions
- URL:=http://hplabs.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html
endef
define Package/wireless-tools/description
@@ -34,6 +38,18 @@ define Package/wireless-tools/description
adapters implementing the "Linux Wireless Extensions".
endef
+define Package/libiw
+$(call Package/wireless-tools/Default)
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Library for manipulating Linux Wireless Extensions
+endef
+
+define Package/libiw/description
+ This package contains a library for manipulating
+ "Linux Wireless Extensions".
+endef
+
define Build/Compile
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
@@ -65,4 +81,10 @@ define Package/wireless-tools/install
ln -sf iwconfig $(1)/usr/sbin/iwspy
endef
+define Package/libiw/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libiw.so.* $(1)/usr/lib/
+endef
+
$(eval $(call BuildPackage,wireless-tools))
+$(eval $(call BuildPackage,libiw))