aboutsummaryrefslogtreecommitdiffstats
path: root/package/wireless-tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 10:49:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 10:49:51 +0000
commitc9a8ed10ca0cce52397e0674f26743184b6c0ff2 (patch)
tree091985213cd789f40add68268fb0e351d02244b6 /package/wireless-tools
parent8a60ff290886ec4a2a10607c02a2e8285dd0f005 (diff)
downloadupstream-c9a8ed10ca0cce52397e0674f26743184b6c0ff2.tar.gz
upstream-c9a8ed10ca0cce52397e0674f26743184b6c0ff2.tar.bz2
upstream-c9a8ed10ca0cce52397e0674f26743184b6c0ff2.zip
fix dependency bug in wireless-tools makefile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2223 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/wireless-tools')
-rw-r--r--package/wireless-tools/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/wireless-tools/Makefile b/package/wireless-tools/Makefile
index b9cbbde1bd..c4767b2127 100644
--- a/package/wireless-tools/Makefile
+++ b/package/wireless-tools/Makefile
@@ -41,7 +41,7 @@ $(IPKG_WIRELESS_TOOLS):
$(RSTRIP) $(IDIR_WIRELESS_TOOLS)
$(IPKG_BUILD) $(IDIR_WIRELESS_TOOLS) $(PACKAGE_DIR)
-install-dev:
+install-dev: $(PKG_BUILD_DIR)/.built
mkdir -p $(STAGING_DIR)/usr/{lib,include}
cp -a $(PKG_BUILD_DIR)/libiw.so* $(STAGING_DIR)/usr/lib/
ln -sf libiw.so.28 $(STAGING_DIR)/usr/lib/libiw.so
@@ -51,5 +51,5 @@ uninstall-dev:
rm -f $(STAGING_DIR)/usr/lib/libiw.*
rm -f $(STAGING_DIR)/usr/include/{iwlib,wireless}.h
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev