aboutsummaryrefslogtreecommitdiffstats
path: root/package/wificonf/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-24 19:58:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-24 19:58:14 +0000
commit8304dfdacebbabb05cf8301c66c4002c543e8888 (patch)
tree056c21ee081ea7e79141723c2b6a0d083c49a348 /package/wificonf/Makefile
parentf91aad926f9e0d34d806454a99f25bac63500b12 (diff)
downloadupstream-8304dfdacebbabb05cf8301c66c4002c543e8888.tar.gz
upstream-8304dfdacebbabb05cf8301c66c4002c543e8888.tar.bz2
upstream-8304dfdacebbabb05cf8301c66c4002c543e8888.zip
move wificonf and nvram stuff back to package/, remove build_mipsel/root, run install part of package/ for every board/kernel - fixes dependency mess
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1540 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/wificonf/Makefile')
-rw-r--r--package/wificonf/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/wificonf/Makefile b/package/wificonf/Makefile
new file mode 100644
index 0000000000..ed41e416c8
--- /dev/null
+++ b/package/wificonf/Makefile
@@ -0,0 +1,30 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wificonf
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/wificonf
+
+include $(TOPDIR)/package/rules.mk
+
+ifneq ($(BOARD),brcm)
+BR2_PACKAGE_WIFICONF:=m
+endif
+
+$(eval $(call PKG_template,WIFICONF,$(PKG_NAME),$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.prepared:
+ mkdir -p $@
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ $(TARGET_CC) $(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -o $(PKG_BUILD_DIR)/wifi wificonf.c -L$(STAGING_DIR)/usr/lib -lnvram -lshared $(STAGING_DIR)/usr/lib/libiw.so
+ touch $@
+
+$(IPKG_WIFICONF):
+ install -d -m0755 $(IDIR_WIFICONF)/sbin
+ install -m0755 $(PKG_BUILD_DIR)/wifi $(IDIR_WIFICONF)/sbin/
+ $(RSTRIP) $(IDIR_WIFICONF)
+ $(IPKG_BUILD) $(IDIR_WIFICONF) $(PACKAGE_DIR)