aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-05-17 21:08:40 +0800
committerPaul Spooren <mail@aparcar.org>2023-05-18 11:35:29 +0200
commit48ed07bc0b94b930d369baf911014bedd5bf6a7e (patch)
treea9b4a50b621a0212b349e73140e8066cf94476d5 /package/utils
parent3a6657540c3d6fc50a63caf8432e301e825ada16 (diff)
downloadupstream-48ed07bc0b94b930d369baf911014bedd5bf6a7e.tar.gz
upstream-48ed07bc0b94b930d369baf911014bedd5bf6a7e.tar.bz2
upstream-48ed07bc0b94b930d369baf911014bedd5bf6a7e.zip
treewide: replace AUTORELEASE with real PKG_RELEASE
Based on Paul Fertser <fercerpav@gmail.com>'s guidance: Change AUTORELEASE in rules.mk to: ``` AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile)) ``` then update all affected packages by: ``` for i in $(git grep -l PKG_RELEASE:=.*AUTORELEASE | sed 's^.*/\([^/]*\)/Makefile^\1^';); do make package/$i/clean done ``` Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/bcm27xx-userland/Makefile2
-rw-r--r--package/utils/dtc/Makefile2
-rw-r--r--package/utils/ugps/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/package/utils/bcm27xx-userland/Makefile b/package/utils/bcm27xx-userland/Makefile
index 857db7969f..9d7f6dd822 100644
--- a/package/utils/bcm27xx-userland/Makefile
+++ b/package/utils/bcm27xx-userland/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=bcm27xx-userland
PKG_VERSION:=c4fd1b8986c6d6d4ae5cd51e65a8bbeb495dfa4e
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/raspberrypi/userland/tar.gz/$(PKG_VERSION)?
diff --git a/package/utils/dtc/Makefile b/package/utils/dtc/Makefile
index 5b1a38d50f..2e20c29cc6 100644
--- a/package/utils/dtc/Makefile
+++ b/package/utils/dtc/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dtc
PKG_VERSION:=1.7.0
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_HASH:=29edce3d302a15563d8663198bbc398c5a0554765c83830d0d4c0409d21a16c4
diff --git a/package/utils/ugps/Makefile b/package/utils/ugps/Makefile
index c70a7b7ea6..5afba4e0b0 100644
--- a/package/utils/ugps/Makefile
+++ b/package/utils/ugps/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ugps
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=2
PKG_SOURCE_URL=$(PROJECT_GIT)/project/ugps.git
PKG_SOURCE_PROTO:=git