aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-07-07 14:10:17 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-07-15 15:21:44 +0200
commitf0c1d26738629972e953829f4d0e3cc643ef1c31 (patch)
tree35d96d7d8c70c216c7e7f0d18507837109770db2 /package/utils
parent50c232d6f446637b7086056f4f78809272572ca3 (diff)
downloadupstream-f0c1d26738629972e953829f4d0e3cc643ef1c31.tar.gz
upstream-f0c1d26738629972e953829f4d0e3cc643ef1c31.tar.bz2
upstream-f0c1d26738629972e953829f4d0e3cc643ef1c31.zip
utils/spidev_test: side-step build-system woes
The spidev_test is build in phase2 even though it should be disabled. My best guess is that we hit the same issue that I had with nu801. The build-system thinks it's a tool that is necessary for building the kernel. In this case, the same fix (adding a dependency on the presence of the module) could work in this case as well? Fixes: bdaaf66e28bd ("utils/spidev_test: build package directly from Linux") Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/spidev_test/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/utils/spidev_test/Makefile b/package/utils/spidev_test/Makefile
index 0f288ad010..a756b3633b 100644
--- a/package/utils/spidev_test/Makefile
+++ b/package/utils/spidev_test/Makefile
@@ -19,7 +19,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/spidev-test
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=+kmod-spi-dev @!IN_SDK
+ DEPENDS:=+PACKAGE_kmod-spi-dev:kmod-spi-dev @!IN_SDK
TITLE:=SPI testing utility
VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
URL:=http://www.kernel.org