aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorOskari Rauta <oskari.rauta@gmail.com>2023-03-19 19:39:25 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-03-25 16:39:37 +0100
commit1558bbd116ec74b10672caa29c17a5f0279715f7 (patch)
tree610aa6a9bc59a47af0a77c2a5472404a592ccc62 /package/utils
parentf598880162e83ddc0139e00c5248497d06f5fff7 (diff)
downloadupstream-1558bbd116ec74b10672caa29c17a5f0279715f7.tar.gz
upstream-1558bbd116ec74b10672caa29c17a5f0279715f7.tar.bz2
upstream-1558bbd116ec74b10672caa29c17a5f0279715f7.zip
util-linux: add rev utility package
I found use for this in my scripts; I noticed that it is already compiled with util-linux - there just isn't package for it - let's package it then. Description: The rev utility copies the specified files to the standard output, reversing the order of characters in everyline. Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/util-linux/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
index 21764a2d27..1ae6bb7b2d 100644
--- a/package/utils/util-linux/Makefile
+++ b/package/utils/util-linux/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=util-linux
PKG_VERSION:=2.38.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.38
@@ -415,6 +415,17 @@ define Package/rename/description
expression in their name by replacement
endef
+define Package/rev
+$(call Package/util-linux/Default)
+ TITLE:=Reverse lines characterwise
+endef
+
+define Package/rev/description
+ rev utility copies the specified files to the standard output, reversing the
+ order of characters in every line. If no files are specified, the standard
+ input is read.
+endef
+
define Package/partx-utils
$(call Package/util-linux/Default)
TITLE:=inform kernel about the presence and numbering of on-disk partitions
@@ -804,6 +815,11 @@ define Package/rename/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/rename $(1)/usr/bin/
endef
+define Package/rev/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/rev $(1)/usr/bin/
+endef
+
define Package/partx-utils/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/partx $(1)/usr/sbin/
@@ -904,6 +920,7 @@ $(eval $(call BuildPackage,namei))
$(eval $(call BuildPackage,nsenter))
$(eval $(call BuildPackage,prlimit))
$(eval $(call BuildPackage,rename))
+$(eval $(call BuildPackage,rev))
$(eval $(call BuildPackage,partx-utils))
$(eval $(call BuildPackage,script-utils))
$(eval $(call BuildPackage,setterm))