aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-07-16 01:34:44 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-07-22 22:26:26 +0200
commitbddfd3f7ed0668346b42f7aff5e6b83e8aea0b38 (patch)
tree22a416f67f557cbdcbb2f12f7c4aeb9ca4c993e9 /package/utils
parent396dc89ee74c833ba3f687b586a1718c13f17900 (diff)
downloadupstream-bddfd3f7ed0668346b42f7aff5e6b83e8aea0b38.tar.gz
upstream-bddfd3f7ed0668346b42f7aff5e6b83e8aea0b38.tar.bz2
upstream-bddfd3f7ed0668346b42f7aff5e6b83e8aea0b38.zip
sdk: add spidev-test to the bundle of userspace sources
moves and extends the current facilities, which have been added some time ago for the the usbip utility, to support more utilites that are shipped with the Linux kernel tree to the SDK. this allows to drop all the hand-waving and code for failed previous attempts to mitigate the SDK build failures. Fixes: bdaaf66e28bd ("utils/spidev_test: build package directly from Linux") Signed-off-by: Christian Lamparter <chunkeey@gmail.com> (cherry picked from commit b479db9062b721776be44b976961a1031c1344ea)
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/spidev_test/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/utils/spidev_test/Makefile b/package/utils/spidev_test/Makefile
index 0f288ad010..fef5c8f646 100644
--- a/package/utils/spidev_test/Makefile
+++ b/package/utils/spidev_test/Makefile
@@ -10,7 +10,6 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=spidev-test
PKG_RELEASE:=$(LINUX_VERSION)
-PKG_FLAGS:=nonshared
PKG_BUILD_DIR:=$(LINUX_DIR)/tools/spi-$(TARGET_DIR_NAME)
PKG_BUILD_PARALLEL:=1
@@ -19,7 +18,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/spidev-test
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=+kmod-spi-dev @!IN_SDK
+ DEPENDS:=+kmod-spi-dev
TITLE:=SPI testing utility
VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
URL:=http://www.kernel.org
@@ -30,6 +29,8 @@ define Package/spidev-test/description
endef
define Build/Prepare
+ # For SDK: Sources are copied by target/sdk/Makefile's
+ # USERSPACE_UTILS(_FILES)
$(CP) $(LINUX_DIR)/tools/spi/* $(PKG_BUILD_DIR)/
endef