aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-05-13 16:23:26 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2021-08-18 20:48:38 +0300
commit8ae3d5f9ca17756ff73db6117784f426a8c6226b (patch)
treec706d4e25579dd2a2148c040e65ac3052185c63b /package/utils
parenta43da1be43ae251f0edaa6419612e600fc6ec972 (diff)
downloadupstream-8ae3d5f9ca17756ff73db6117784f426a8c6226b.tar.gz
upstream-8ae3d5f9ca17756ff73db6117784f426a8c6226b.tar.bz2
upstream-8ae3d5f9ca17756ff73db6117784f426a8c6226b.zip
busybox: fix compilation with GCC 10
When compiling busybox with GCC 10 and CONFIG_PKG_ASLR_PIE_ALL=y, there are hundreds of errors like: relocation R_MIPS16_26 against `xzalloc' cannot be used when making a shared object; recompile with -fPIC Simply solve this by no longer disabling PKG_ASLR_PIE, so that $(FPIC) is properly added to the CFLAGS and LDFLAGS. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Acked-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/busybox/Makefile3
1 files changed, 0 insertions, 3 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 32f0d2c755..76a1de33b7 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -18,9 +18,6 @@ PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_PAM:libpam
PKG_BUILD_PARALLEL:=1
PKG_CHECK_FORMAT_SECURITY:=0
-#Busybox use it's own PIE config flag and LDFLAGS are used with ld, not gcc.
-PKG_ASLR_PIE:=0
-
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=LICENSE archival/libarchive/bz/LICENSE
PKG_CPE_ID:=cpe:/a:busybox:busybox