aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorSergey V. Lobanov <sergey@lobanov.in>2022-01-02 22:18:04 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2022-01-08 00:49:59 +0100
commit04e6434c62dc8271767f3c675832647477eb9998 (patch)
tree13912151bc6eb8b0d2c580bc3af09512f16c3d05 /package/utils
parent033b6cef94a4aae6244f75f34bc2879869335002 (diff)
downloadupstream-04e6434c62dc8271767f3c675832647477eb9998.tar.gz
upstream-04e6434c62dc8271767f3c675832647477eb9998.tar.bz2
upstream-04e6434c62dc8271767f3c675832647477eb9998.zip
utils/mdadm: fix build on hosts without /run dir
CHECK_RUN_DIR=0 must be a part of MAKE_FLAGS, not MAKE_VARS, otherwise it is not possible to compile mdadm on host without /run dir. Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/mdadm/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/utils/mdadm/Makefile b/package/utils/mdadm/Makefile
index f20a58b704..f6696bf21c 100644
--- a/package/utils/mdadm/Makefile
+++ b/package/utils/mdadm/Makefile
@@ -52,7 +52,7 @@ TARGET_CFLAGS += \
TARGET_LDFLAGS += -Wl,--gc-sections
-MAKE_VARS += CHECK_RUN_DIR=0
+MAKE_FLAGS += CHECK_RUN_DIR=0
define Build/Compile
$(call Build/Compile/Default,mdadm)