aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2020-03-27 12:40:33 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2022-02-05 17:48:56 +0200
commit2c929f8105237d3ebd645ea4e3387585c139b6ab (patch)
tree623ed11678015039592fe9f05df6c0e254514aeb /package/utils
parent3f4301e123f29348b4ad87578d62b7d1f5f210c6 (diff)
downloadupstream-2c929f8105237d3ebd645ea4e3387585c139b6ab.tar.gz
upstream-2c929f8105237d3ebd645ea4e3387585c139b6ab.tar.bz2
upstream-2c929f8105237d3ebd645ea4e3387585c139b6ab.zip
util-linux: package ipcs command
Add a package for util-linux' ipcs command, to show information about System V inter-process communication facilities. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/util-linux/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
index f2d58b413f..ce3cd171e0 100644
--- a/package/utils/util-linux/Makefile
+++ b/package/utils/util-linux/Makefile
@@ -265,6 +265,18 @@ define Package/hwclock/description
hwclock is a tool for accessing the Hardware Clock
endef
+define Package/ipcs
+$(call Package/util-linux/Default)
+ TITLE:=show information on IPC facilities
+endef
+
+define Package/ipcs/description
+ ipcs shows information on the inter-process communication facilities for
+ which the calling process has read access. By default it shows information
+ about all three resources: shared memory segments, message queues, and
+ semaphore arrays.
+endef
+
define Package/logger
$(call Package/util-linux/Default)
TITLE:=a shell command interface to the syslog system log module
@@ -690,6 +702,11 @@ define Package/hwclock/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/hwclock $(1)/usr/sbin/
endef
+define Package/ipcs/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ipcs $(1)/usr/bin/
+endef
+
define Package/logger/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/logger $(1)/usr/bin/util-linux-logger
@@ -842,6 +859,7 @@ $(eval $(call BuildPackage,flock))
$(eval $(call BuildPackage,fstrim))
$(eval $(call BuildPackage,getopt))
$(eval $(call BuildPackage,hwclock))
+$(eval $(call BuildPackage,ipcs))
$(eval $(call BuildPackage,logger))
$(eval $(call BuildPackage,look))
$(eval $(call BuildPackage,losetup))