aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2021-11-01 19:27:00 +0100
committerJo-Philipp Wich <jo@mein.io>2022-01-28 19:13:37 +0100
commit0a29133b1f1ebae60c6fe65281e52e1ade6d388d (patch)
treea74d6d23bbb4ae624ecb2c3507276d63f61eeaf8 /package/utils
parenta47f15294324462192acd6c2f304f888ff609cb4 (diff)
downloadupstream-0a29133b1f1ebae60c6fe65281e52e1ade6d388d.tar.gz
upstream-0a29133b1f1ebae60c6fe65281e52e1ade6d388d.tar.bz2
upstream-0a29133b1f1ebae60c6fe65281e52e1ade6d388d.zip
ucode: update to latest Git HEAD
c6dae42 LICENSE: add ISC license file 402f603 lib: introduce struct library dcb6ffd struct: fix PowerPC specific compiler pragma name a0512ea treewide: fix typo in exported function names and types eaaaf88 nl80211: fix wiphy dump reply merge logic e6efadb fs: add utility functions 54ef6c0 nl80211: fix premature netlink reply receive abort 07802f3 syntax: disallow keywords in object property shorthand notation 3489b75 vm: support object property access on resource value types dc8027c types: consider resource prototypes when marking reachable objects 5680fab treewide: fix upvalue reference type name 0d29b25 treewide: fix "resource" misspellings 99fdafd vm: introduce value registry 66f7c00 ubus: add support for async requests 5c77dd5 fs: implement fdopen(), file.fileno() and proc.fileno() b605dbf treewide: rework numeric value handling 599d233 vallist: store double values in a platform neutral manner 5bb9ab7 struct: reuse double packing routines from core 2fd7ab5 vm: optimize string concatenation eafa321 lib: implement uniq() function 6b2e79a types: add initial infrastructure for function serialization 725bb75 compiler, vm: use a program wide constant list 6c2caf9 source: refactor source file handling 371ba45 program: implement support for precompiling source files 3578afe build: support building without compile capabilities 61d0a34 lib: replace usages of vasprintf() with xvasprintf() 03b6a8e syntax: drop legacy syntax support 01132db lib: fix %J string formats with precision specifier 3f44c42 lib: rework format string handling a1b3c5d struct: implement `*` format, fix invalid memory accesses 34a04a2 run_tests.sh: fix exitcode evaluation abe38e7 run_tests.sh: add ability to define environment variables for testcases 04fa2ba tests: reorganize testcase files 6a55d10 lib: fix exists() error return value aa860a3 vm: fix `null` loose equality/inequality checks 3f6d199 vallist: uc_number_parse(): parse empty strings as `0`, not `NaN` ddc5aa7 vm: fix NaN strict equality tests Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/ucode/Makefile27
-rw-r--r--package/utils/ucode/patches/100-fix-int-format-on-32bit-system.patch11
2 files changed, 22 insertions, 16 deletions
diff --git a/package/utils/ucode/Makefile b/package/utils/ucode/Makefile
index beafb94bb4..f53a3a3529 100644
--- a/package/utils/ucode/Makefile
+++ b/package/utils/ucode/Makefile
@@ -8,17 +8,17 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ucode
-PKG_RELEASE:=2
+PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=https://github.com/jow-/ucode.git
-PKG_SOURCE_DATE:=2021-10-25
-PKG_SOURCE_VERSION:=a7976c2802a9da737f62bec496c7115211c442a7
-PKG_MIRROR_HASH:=6bc3ddeef41d68fd96894957356472e576c625fcf7277cbb36aa464b8d3c274d
+PKG_SOURCE_DATE:=2022-01-26
+PKG_SOURCE_VERSION:=ddc5aa7cd3121300f2ba6e68cb038258a616d4e4
+PKG_MIRROR_HASH:=f9a3c010c54288a2363757b58ef31a827b8314e444bb7bf48926f7d4ea88b9d6
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_LICENSE:=ISC
-PKG_ABI_VERSION:=20210730
+PKG_ABI_VERSION:=20220120
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
@@ -109,6 +109,17 @@ define Package/ucode-mod-rtnl/description
endef
+define Package/ucode-mod-struct
+ $(Package/ucode/default)
+ TITLE+= (struct module)
+ DEPENDS:=ucode
+endef
+
+define Package/ucode-mod-struct/description
+ The struct plugin implemnts Python 3 compatible struct.pack/unpack functionality.
+endef
+
+
define Package/ucode-mod-ubus
$(Package/ucode/default)
TITLE+= (ubus module)
@@ -174,6 +185,11 @@ define Package/ucode-mod-rtnl/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/rtnl.so $(1)/usr/lib/ucode/
endef
+define Package/ucode-mod-struct/install
+ $(INSTALL_DIR) $(1)/usr/lib/ucode
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/struct.so $(1)/usr/lib/ucode/
+endef
+
define Package/ucode-mod-ubus/install
$(INSTALL_DIR) $(1)/usr/lib/ucode
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/ubus.so $(1)/usr/lib/ucode/
@@ -192,5 +208,6 @@ $(eval $(call BuildPackage,ucode-mod-math))
$(eval $(call BuildPackage,ucode-mod-nl80211))
$(eval $(call BuildPackage,ucode-mod-resolv))
$(eval $(call BuildPackage,ucode-mod-rtnl))
+$(eval $(call BuildPackage,ucode-mod-struct))
$(eval $(call BuildPackage,ucode-mod-ubus))
$(eval $(call BuildPackage,ucode-mod-uci))
diff --git a/package/utils/ucode/patches/100-fix-int-format-on-32bit-system.patch b/package/utils/ucode/patches/100-fix-int-format-on-32bit-system.patch
deleted file mode 100644
index c557d0c1bd..0000000000
--- a/package/utils/ucode/patches/100-fix-int-format-on-32bit-system.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/lib.c
-+++ b/lib.c
-@@ -1438,7 +1438,7 @@ uc_printf_common(uc_vm_t *vm, size_t nar
-
- switch (t) {
- case UC_INTEGER:
-- ucv_stringbuf_printf(buf, sfmt, arg.n);
-+ ucv_stringbuf_printf(buf, sfmt, (int)arg.n);
- break;
-
- case UC_DOUBLE: