aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2017-07-05 16:25:23 +0200
committerJo-Philipp Wich <jo@mein.io>2017-12-13 16:23:38 +0100
commitea23ba9a250714302e9fc21bfc52293b3cddfddd (patch)
treed7d58bd3c0025f21aa7a3b21e4c41d5ea22d6b03 /package/utils
parentd413c75d24f9fe231b992c47b1367b095f4571fc (diff)
downloadupstream-ea23ba9a250714302e9fc21bfc52293b3cddfddd.tar.gz
upstream-ea23ba9a250714302e9fc21bfc52293b3cddfddd.tar.bz2
upstream-ea23ba9a250714302e9fc21bfc52293b3cddfddd.zip
bzip2: add symlink to binary
Other distributions incl. the OpenWrt ImageBuilder and SDK expect to find the bzip2 executable in /bin. Create a symlink at that location for compatibility. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit eb7c14d512482e18d05f61afa44205167ea094c0)
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/bzip2/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/utils/bzip2/Makefile b/package/utils/bzip2/Makefile
index c17dee136b..62c255a907 100644
--- a/package/utils/bzip2/Makefile
+++ b/package/utils/bzip2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=bzip2
PKG_VERSION:=1.0.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.bzip.org/$(PKG_VERSION)
@@ -82,6 +82,8 @@ endef
define Package/bzip2/install
$(INSTALL_DIR) $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bzip2-shared $(1)/usr/bin/bzip2
+ $(INSTALL_DIR) $(1)/bin/
+ $(LN) ../usr/bin/bzip2 $(1)/bin/bzip2
endef
HOST_CFLAGS += \