aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-03-16 12:32:22 +0000
committerNicolas Thill <nico@openwrt.org>2015-03-16 12:32:22 +0000
commitd951b2beb11b3c74babeea15b628d583e10e6fff (patch)
tree6aa81f7d1c1dba2e110a17089da1ee67bf344167 /package/utils
parent7105a54bcb1ec09bd71ed530ef16ac39a08c06c3 (diff)
downloadupstream-d951b2beb11b3c74babeea15b628d583e10e6fff.tar.gz
upstream-d951b2beb11b3c74babeea15b628d583e10e6fff.tar.bz2
upstream-d951b2beb11b3c74babeea15b628d583e10e6fff.zip
packages: more (e)glibc fixes after r44701
_GNU_SOURCE has been declared "deprecated" in favor of _DEFAULT_SOURCE in glibc Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44843 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/ugps/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/utils/ugps/Makefile b/package/utils/ugps/Makefile
index c1bc7cdd01..3662125c3a 100644
--- a/package/utils/ugps/Makefile
+++ b/package/utils/ugps/Makefile
@@ -32,6 +32,10 @@ endef
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+ifneq ($(CONFIG_USE_GLIBC),)
+ TARGET_CFLAGS += -D_DEFAULT_SOURCE
+endif
+
define Package/ugps/install
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d $(1)/etc/config
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ugps $(1)/usr/sbin/