aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-06-18 10:10:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-06-18 10:10:30 +0000
commita586bc77e71b57e59b054e79838b20a396348df6 (patch)
tree6f88b18ab3d8c04050519cb65b218155ab39218f /package/utils
parentd8e56de762bc32636f9e00ed586e2aa1aa90e36d (diff)
downloadupstream-a586bc77e71b57e59b054e79838b20a396348df6.tar.gz
upstream-a586bc77e71b57e59b054e79838b20a396348df6.tar.bz2
upstream-a586bc77e71b57e59b054e79838b20a396348df6.zip
jsonpath: rename to jsonfilter and rewrite from flex/bison to lemon
This commit renames the jsonpath binary to jsonfilter to avoid clashing with a Python extension of the same name. The utility itself has been rewritten to use SQLite3's lemon parser generator instead of a flex/bison combination which results in a much smaller binary. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41258 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/jsonfilter/Makefile (renamed from package/utils/jsonpath/Makefile)17
1 files changed, 9 insertions, 8 deletions
diff --git a/package/utils/jsonpath/Makefile b/package/utils/jsonfilter/Makefile
index be64fed856..1ddb22f3f1 100644
--- a/package/utils/jsonpath/Makefile
+++ b/package/utils/jsonfilter/Makefile
@@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=jsonpath
-PKG_VERSION:=2014-01-08
+PKG_NAME:=jsonfilter
+PKG_VERSION:=2014-06-18
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=http://git.openwrt.org/project/jsonpath.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=f1e3aeb2526ea28db34c7bc714277c1dff26e5fc
+PKG_SOURCE_VERSION:=c0e1d4495a8afe51cc1900269d6a6fcf0b51a761
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
@@ -16,16 +16,17 @@ PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
-define Package/jsonpath
+define Package/jsonfilter
SECTION:=base
CATEGORY:=Base system
DEPENDS:=+libubox +libjson-c
- TITLE:=OpenWrt JSON query utility
+ TITLE:=OpenWrt JSON filter utility
+ URL:=http://git.openwrt.org/?p=project/jsonpath.git
endef
-define Package/jsonpath/install
+define Package/jsonfilter/install
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/jsonpath $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/jsonpath $(1)/usr/bin/jsonfilter
endef
-$(eval $(call BuildPackage,jsonpath))
+$(eval $(call BuildPackage,jsonfilter))