aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-01-02 11:55:16 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-01-02 11:55:16 +0000
commit3494713f4d06aada91622bcf9c21c2ea4eed69cf (patch)
treeba1931e759392863995cfdc12b7a8053bd8f1fe0 /package/utils
parent51b9513ec533b0147f54293196dd0fbbbe901ce3 (diff)
downloadupstream-3494713f4d06aada91622bcf9c21c2ea4eed69cf.tar.gz
upstream-3494713f4d06aada91622bcf9c21c2ea4eed69cf.tar.bz2
upstream-3494713f4d06aada91622bcf9c21c2ea4eed69cf.zip
Add jsonpath - a command line utility to extract values from JSON data using XPath-like expressions
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39185 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/jsonpath/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/package/utils/jsonpath/Makefile b/package/utils/jsonpath/Makefile
new file mode 100644
index 0000000000..9e44cf27a5
--- /dev/null
+++ b/package/utils/jsonpath/Makefile
@@ -0,0 +1,31 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=jsonpath
+PKG_VERSION:=2014-01-02
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://git.openwrt.org/project/jsonpath.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=325454c60f282994cf79c69d49edbcea53f2e924
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+CMAKE_INSTALL:=1
+
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/jsonpath
+ SECTION:=base
+ CATEGORY:=Base system
+ DEPENDS:=+libubox +libjson-c
+ TITLE:=OpenWrt JSON query utility
+endef
+
+define Package/jsonpath/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/jsonpath $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,jsonpath))