aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/util-linux
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke.mehrtens@intel.com>2017-04-13 18:07:05 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2017-05-24 18:04:51 +0200
commitd179aa87698d18ca18cda11425229328822c7f06 (patch)
tree665104f0c861d829f3a722051bf1b937c9ad30d0 /package/utils/util-linux
parentdd19a41520c54f13f9d9da2f5ff7dcebd3d8f085 (diff)
downloadupstream-d179aa87698d18ca18cda11425229328822c7f06.tar.gz
upstream-d179aa87698d18ca18cda11425229328822c7f06.tar.bz2
upstream-d179aa87698d18ca18cda11425229328822c7f06.zip
util-linux: fix build with uclibc
Fix build of scriptreplay with uClibc. Some parts of the libm detection were backported to 2.29.2, but some parts were missing, which are added here. This patch is needed when libm is a separate library, this is not needed for LEDE master, because libm is there integrated in the libc for uClibc and musl. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
Diffstat (limited to 'package/utils/util-linux')
-rw-r--r--package/utils/util-linux/patches/001-uclibc_add_libm_to_scriptreplay.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/utils/util-linux/patches/001-uclibc_add_libm_to_scriptreplay.patch b/package/utils/util-linux/patches/001-uclibc_add_libm_to_scriptreplay.patch
new file mode 100644
index 0000000000..a291f6ac86
--- /dev/null
+++ b/package/utils/util-linux/patches/001-uclibc_add_libm_to_scriptreplay.patch
@@ -0,0 +1,24 @@
+From feda4342df1ced25df3d200ed23469e740196c86 Mon Sep 17 00:00:00 2001
+From: Karel Zak <kzak@redhat.com>
+Date: Wed, 18 Jan 2017 13:17:21 +0100
+Subject: build-sys: use -lm for scriptreplay if necessary
+
+Reported-by: Bert van Hall <bert.vanhall@avionic-design.de>
+Addresses: https://github.com/karelzak/util-linux/pull/397
+Signed-off-by: Karel Zak <kzak@redhat.com>
+---
+ configure.ac | 7 +++++++
+ term-utils/Makemodule.am | 2 +-
+ 2 files changed, 8 insertions(+), 1 deletion(-)
+
+--- a/term-utils/Makemodule.am
++++ b/term-utils/Makemodule.am
+@@ -21,7 +21,7 @@ if BUILD_SCRIPTREPLAY
+ usrbin_exec_PROGRAMS += scriptreplay
+ dist_man_MANS += term-utils/scriptreplay.1
+ scriptreplay_SOURCES = term-utils/scriptreplay.c
+-scriptreplay_LDADD = $(LDADD) libcommon.la
++scriptreplay_LDADD = $(LDADD) libcommon.la $(MATH_LIBS)
+ endif # BUILD_SCRIPTREPLAY
+
+