aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/util-linux/patches
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2017-03-22 12:13:12 +0100
committerJohn Crispin <john@phrozen.org>2017-03-22 12:14:08 +0100
commitaa729bcf14e379cb64ad6c83f02ac6ce03d1a8fc (patch)
treea16dc9599c8e3275cc9cb9f87b66daab63b917a7 /package/utils/util-linux/patches
parent8a4208d5af7a14f4e658a6da2d1a1020f0f99cba (diff)
downloadupstream-aa729bcf14e379cb64ad6c83f02ac6ce03d1a8fc.tar.gz
upstream-aa729bcf14e379cb64ad6c83f02ac6ce03d1a8fc.tar.bz2
upstream-aa729bcf14e379cb64ad6c83f02ac6ce03d1a8fc.zip
Revert "utils/util-linux: Update to 2.29.2"
This reverts commit eac1a548573a0262e9f36aeee95ed071f6040703. This patch caused the builders to blow up. Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'package/utils/util-linux/patches')
-rw-r--r--package/utils/util-linux/patches/0001-fix-uClibc-ng-scanf-check.patch34
-rw-r--r--package/utils/util-linux/patches/003-fix_pkgconfig_files.patch2
2 files changed, 35 insertions, 1 deletions
diff --git a/package/utils/util-linux/patches/0001-fix-uClibc-ng-scanf-check.patch b/package/utils/util-linux/patches/0001-fix-uClibc-ng-scanf-check.patch
new file mode 100644
index 0000000000..2da95f6cdb
--- /dev/null
+++ b/package/utils/util-linux/patches/0001-fix-uClibc-ng-scanf-check.patch
@@ -0,0 +1,34 @@
+From 180c908e2e80552b19bf3552667fc197d6edf7b3 Mon Sep 17 00:00:00 2001
+From: Waldemar Brodkorb <wbx@uclibc-ng.org>
+Date: Fri, 3 Jun 2016 04:13:08 +0200
+Subject: [PATCH] fix uClibc-ng scanf check
+
+uClibc-ng tries to be compatible with GNU libc and defines
+__GLIBC__ and pretend to be version 2.2.
+We once changed it to 2.10, but then some hard to fix problems
+in different software packages (gcc) occured.
+It would be better if we disable the special GNU libc checks
+for uClibc-ng here. uClibc-ng implements the required scanf
+functionality.
+
+Signed-off-by: Waldemar Brodkorb <wbx@uclibc-ng.org>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index f36b18c..4661c0d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -581,7 +581,7 @@ AC_CACHE_VAL([scanf_cv_alloc_modifier],
+ #include <stdio.h>
+ #include <unistd.h>
+
+- #ifdef __GLIBC__
++ #if defined(__GLIBC__) && !defined(__UCLIBC__)
+
+ #if !(__GLIBC_PREREQ(2, 7))
+ #error %m is not available
+--
+2.1.4
+
diff --git a/package/utils/util-linux/patches/003-fix_pkgconfig_files.patch b/package/utils/util-linux/patches/003-fix_pkgconfig_files.patch
index 16ba14ae35..cc9cd11188 100644
--- a/package/utils/util-linux/patches/003-fix_pkgconfig_files.patch
+++ b/package/utils/util-linux/patches/003-fix_pkgconfig_files.patch
@@ -10,7 +10,7 @@
endif # BUILD_LIBUUID
--- a/configure.ac
+++ b/configure.ac
-@@ -2165,18 +2165,23 @@ AC_CONFIG_HEADERS([config.h])
+@@ -2122,18 +2122,23 @@ AC_CONFIG_HEADERS([config.h])
#
AC_CONFIG_FILES([
Makefile